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1   Introduction 

This document introduces the operating method of the TU20 Pro and TU15 Pro to help users get started 

with the LED playback control processors quickly. 

The TU20 Pro and TU15 Pro are playback control processors specially designed by Xi’an NovaStar Tech 

Co., Ltd. (hereinafter referred to as NovaStar) for indoor LED screens. They integrate the Android system 

and sending card functions into one unit, and allow third-party apps to run on them, featuring powerful 

interaction and playback control capabilities. 

The TU20 Pro and TU15 Pro support wireless screen mirroring from Windows, macOS, iOS and Android 

terminals. For a standard 1080p video, the mirroring transmission is at up to 60 fps with a system latency 

of less than or equal to 80 ms at 8 meters. For different application scenarios, it provides 4 modes to let 

the document presentation, video playback and remote meetings have the optimal display effect. 

In addition, the TU20 Pro and TU15 Pro support control by the ViPlex Handy and VNNOX Care apps. 

 With ViPlex Handy, you can effortlessly perform program editing, program publishing, screen control, 

and screen mirroring. For related operations, please refer to the ViPlex Handy Media Player Control 

App User Manual. 

 With VNNOX Care, you can easily perform screen configuration, screen topology and automatic screen 

configuration backup. You can also complete screen topology mapping by taking photos and gain 

access to features like cloud module and seam correction. For related operations, please refer to the 

help center of VNNOX Care. 

 

TU20 Pro and TU15 Pro share the same operations. The screenshots provided in this document take the 

TU20 Pro as examples. 
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2   Getting Started 

Do the following steps to quickly get started with the LED playback control processors. 

Step 1: Set up the Hardware 

Step 1 Open the package. 

Step 2 Prepare the accessories, such as Ethernet cable, remote, and mirroring dongle. 

Step 3 Build the hardware environment according to the following diagram. You can also connect common 

peripherals as needed, such as mouse, keyboard, sound system, camera and infrared touch frame. 

Figure 2-1 Hardware architecture 

 

Step 4 Connect the Ethernet cables from the LED screen to the Ethernet output ports of TU20 Pro/TU15 Pro 

in the order shown below. 

Figure 2-2 Rear panel – TU20 Pro (6 Ethernet ports) / TU15 Pro (4 Ethernet ports) 
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Step 5 Connect the power cable to power on the device. 

Step 2: Install Related Apps 

Search for ViPlex Handy and VNNOX Care in the app store, download and install them. 

 With ViPlex Handy, you can effortlessly perform program editing, program publishing, and screen 

control. 

 With VNNOX Care, you can easily perform screen configuration, screen topology, seam correction, and 

automatic screen configuration backup. 

Step 3 Configure the LED Screen 

Step 1 Open VNNOX Care app. 

Step 2 On the Local Config tab page, tap Connect to Hotspot, select the hotspot of the device, and enter the 

password to connect to the hotspot. 

Step 3 On the Local Config tab page, tap Quick Start and follow the instructions to complete screen 

configuration. 

For detailed steps, tap Profile > User Manual to see the user manual. 

Step 4 Initialize the System 

For the first-time use of the LED playback control processor, do the following steps to complete the 

initialization settings. 

Step 1 Set the system language. English, Simplified Chinese, Traditional Chinese, Japanese, Russian, Korean, 

Portuguese, Spanish, and Italian are now available. 

Figure 2-3 Select a language 

 

Step 2 To pair the remote using Bluetooth, point it at the device's infrared sensor. Then, simultaneously press 

and hold the Home and Menu buttons on the remote until you see the Connecting to the remote 

window pop up. 
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Figure 2-4 Pair with the remote 

 

Step 3 Read and agree to the Service Agreement. 

Figure 2-5 Service agreement 

 

Step 4 Select a time tone. 

Figure 2-6 Select a time zone 

 

Step 5 Select the Wi-Fi network you want to connect to and enter the password. Then, click Connect. 
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Figure 2-7 Connect to Wi-Fi 

 

Figure 2-8 Enter password 

 

Note 

The password must be at least 8 characters long. 

Step 6 Rename your device to make it easier to search and connect from other devices. 

Figure 2-9 Rename your device 
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Note 

The hotspot name will be updated automatically if you rename the device. 

Step 7 The initialization settings are done. You can start using the LED playback control processor. 
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3   Usage of the Remote 

Buttons on the Remote 

Figure 3-1 Description of buttons on the remote 

 

Bluetooth Pairing Method 

Point the remote at the device's infrared sensor and hold down the Menu and Home buttons 

simultaneously until the Connecting to the remote window appears at the bottom of the screen. 
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4   Screen Mirroring 

Wireless Mirroring 

Ensure that the network is connected before using wireless screen mirroring. For details, please refer to 

Step 5 in 2   Getting Started. 

4.1.1   Mirror from Mobile Phone 

Screen mirroring on ViPlex Handy 

Step 1 On the main screen, click  to navigate to the screen mirroring settings. 

Figure 4-1 Wireless mirroring 

 

Step 2 Scan the QR code on the screen to download and install ViPlex Handy on your phone. 

Step 3 Open the ViPlex Handy and tap Local Control on the main page. 

Step 4 Connect your phone to the hotspot of the LED playback control processor (default name: TUxx 

Pro_xxxx; default password: SN2008@+). 

Step 5 Navigate to Local Devices and select the device you want to connect. 

Step 6 Return to the main page and tap Screen Interactive. 
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Figure 4-2 Screen interaction 

 

Step 7 Do the following as required. 

 Display image: Select an image from the album and display it on the screen. Swipe left or right to 

switch between images. 

Figure 4-3 Display image 

 

 Display video: Select a video from the album and display it on the screen. It will return to the video 

selection interface once the playback is finished. 

You can pause/resume the playback, drag the playback progress, adjust the volume, and switch videos 

with the remote. 
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Figure 4-4 Display video 

 

 Display document: Select a document from the file explorer and display it on the screen. Use the 

remote to scroll through pages and move the cursor (Supported file formats include PPT, WORD, PDF, 

and EXCEL. This feature is not supported by iOS). 

Figure 4-5 Display document 

 

 Mirror screen: You can mirror the display of the phone/tablet onto the screen. Tap Screen Mirroring to 

starting mirroring and tap Stop Mirroring to stop. You can also open the floating window  and tap 

Stop to stop mirroring. 
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Figure 4-6 Screen mirroring & Stop mirroring 

  

Note: 

 Tap  on top of the interface and then tap Stop to stop. 

 Please enable the floating window permission for ViPlex Handy before mirroring screen. 

 For iOS devices, you can only start mirroring after enabling Screen Mirroring in the control center. To 

stop the mirroring, simply disable Screen Mirroring. 

 Other screen casting functions will be unavailable when using the screen mirroring function. 

 Secondary mirroring: Control the display screen in real-time on your phone/tablet. 

 Remote: On the Device Management or screen mirroring interface, tap Remote to perform operations 

such as clicking, swiping, returning to the main menu, going back to the previous menu, adjusting 

volume, and zooming in or out of the display screen with two fingers (for images and documents). 
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Figure 4-7 Remote 

 

Mirroring from iOS 

Step 1 Connect your phone to the hotspot of the LED playback control processor (default name: TUxx 

Pro_xxxx; default password: SN2008@+). 

Step 2 Open the control center. 

Step 3 Tap Screen Mirroring and select the device to start mirroring. 
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Figure 4-8 Screen mirroring - iOS 

 

4.1.2   Mirroring from PC 

Mirroring from Windows 

Step 1 On the PC, open a browser, enter the website address “meexus.cn/English.html” and download the 

LinkED for Windows client. 

 

Step 2 Connect the PC to hotspot of the LED playback control processor (default name: TUxx Pro_xxxx; 

default password: SN2008@+). 

Step 3 Run the client on the PC. The connected device will be detected by the client automatically. Then, click 

Start projection. 
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Mirroring from macOS 

Step 1 Connect the PC to hotspot of the LED playback control processor (default name: TUxx Pro_xxxx; 

default password: SN2008@+). 

Step 2 Click the AirPlay icon in the menu bar at the top of your screen, and select the device you want to 

mirror the screen to. 

Figure 4-9 Screen mirroring - Mac 

 

4.1.3   Mirroring via Dongle 

Note 

To mirroring the screen via dongle, conenct to the Internet to activate the TU device. 

Step 1 For the first-time use, or after you change the device name, hotspot name or hotspot password, you 

must insert the mirroring dongle into the USB port of the LED Playback control processor for pairing. 

Step 2 Insert the paired dongle into the USB port of the PC. 
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Figure 4-10 Connection successful 

 

Step 3 When a pop-up window with the “Connection successful” message appears on the desktop, press the 

round button on the dongle to start mirroring. 

Note: 

When using the mirroring dongle to mirror from the macOS PC for the first time, authorization is required. 

(The following operations use the 10.13.6 version as an example.) 

1. On the desktop, open the PTB USB drive. 

 

2. Double click the Client program to run it. 

3. Follow the instructions to complete the authorization. 

4.1.4   Mirror Screen Settings 

Step 1 On the main screen, click  to navigate to the screen mirroring settings. 
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Figure 4-11 Wireless mirroring 

 

Step 2 Press the OK button on the remote to open the screen mirroring setup interface. 

Figure 4-12 Mirror Screen Settings 

 

Step 3 Do the following as required. 

 Version: Check the mirroring dongle version. 

 Activation information: Click to check the activation status, activation code, MAC address, and split-

screen quantity. 

 Smart whiteboard pen: Click to use the smart whiteboard pen. 

 Device name. Check the device name. 

 Screen code: Set a screen code if enabled. 

 Display mode: Set the display mode. Available options include Proportional, Full Screen, and 

Adaptive. 

 Show slide navigation icons: Click to show/hide navigation icons for slides. 
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 Show master control ball: Click to show/hide the master control ball. 

 Primary mirroring dongle: Click to enable/disable the primary mirroring dongle. 

 DLNA cast: Click to enable/disable DLNA mirroring. 

 Split-screen mode: Set the split-screen mode. Available options include Full Screen, Two-Split Screen, 

and Four-Split Screen. 

 Activation upgrade: Click and enter the activation code in the pop-up window and press OK to 

activate. 

 Mirroring timeout: Click and select mirroring timeout in the popup window, available options include 

15s/30s/45s/60s. 
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Wired Mirroring 

4.2.1   Connect Signal Source 

Connect the LED playback control processor to the device you want to mirror the screen from via HDMI 

cable. 

Figure 4-13 Wired mirroring 

 

4.2.2   Switch Signal Source 

You can switch the signal source via the following method. 

Step 1 On the main screen, click  or press the Menu button on the remote to open the signal source 

adjustment window. 

Figure 4-14 Signal source 
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Step 2 Select the signal source that you want to display, and press the OK button on the remote. 

5   Secondary Screen 

Access the Secondary Screen 

Step 1 To access the secondary screen interface, first navigate the cursor to the left of the home screen, then 

press the Left button on the remote again. In this interface, you can find details such as the device 

name, system version, product serial number (SN), memory status, and storage information. 

Figure 5-1 Secondary screen homepage 

 

Step 2 To view more information, click More and you will be redirected Settings > System > About > Device 

Information. For more details, please refer to 8.7.1   About. 

Step 3 On the right side of the secondary screen's homepage, you can click Wired Network, Wi-Fi, Hotspot, 

and Bluetooth to redirect to Settings > Network > Wired Network\Wireless 

Network\Hotspot\Bluetooth. For more details, please refer to section 8.1.1   Wired network to 

section 8.1.4 Hotspot. 

Quick Start Guide 

Step 1 To access the Quick Start Guide, simple click Quick Start Guide at the bottom of the secondary 

screen's homepage. 
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Figure 5-2 Quick start guide 

 

Step 2 Press the Left/Right buttons on the remote to navigate through Pair with Remote, Pair with Dongle, 

Home App Customization, App Switcher, and Effect Mode. 

 Click Pair with Remote to open the remote pairing instruction screen. 

Figure 5-3 Pair with remote 

 

 Click Pair with Dongle to open the dongle pairing instruction screen. 
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Figure 5-4 Pair with dongle 

 

 Click Home App Customization to open the home app instruction screen. 

Figure 5-5 Home app customization 

 

 Click App Switcher to open the app switcher instruction screen. 
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Figure 5-6 App switcher 

 

 Click Effect Mode to open the effect mode instruction screen. 

Figure 5-7 Effect mode 

 

Step 3 On the right side of the secondary screen's homepage, you can click Wired Network, Wi-Fi, Hotspot, 

and Bluetooth to redirect to Settings > Network > Wired Network\Wireless 

Network\Hotspot\Bluetooth. For more details, please refer to section 8.1.1   Wired network to 

section 8.1.4 Hotspot. 

Diagnostics 

The diagnostic feature is used when various issues arise during device usage, such as flickering screens, 

disconnections during mirroring, audio output failure, unrecognized USB drives, and more. With device 

diagnostics, users can promptly identify and pinpoint the issues, thus improving the overall experience. 

Step 1 To access diagnostics, simple click Diagnostics at the bottom of the secondary screen's homepage. 
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Figure 5-8 Diagnostics 

 

Step 2 Click Run Diagnostics to run tests on Hardware Detection, Operating Status Detection, Display 

Detection, and Network Detection. 

Figure 5-9 Running diagnostics 

 

Step 3 Once the diagnostic process is complete, you will see either Device normal or Device abnormal 

displayed on the left. On the right, you can view the test items categorized as Normal, Abnormal, or 

Not tested. To see detailed information about all detected items, click View Report. 
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Figure 5-10 Diagnostic result 

 

FAQ 

Step 1 To access FAQ, simple click FAQ at the bottom of the secondary screen's homepage. 

Figure 5-11 FAQ 

 

Step 2 Use the remote's Up and Down buttons to toggle between the categories of issues on the left, then 

press OK to view the specific questions. 

6   File Explorer 

Manage Device Files 

You can manage the files or folders within the device. This section will illustrate the process using folder 

management as an example. 
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Step 1 On the main screen of the system, click  to open the File Explorer interface. 

Figure 6-1 File explorer 

 

Step 2 You can view and manage files by file path. 

In the Devices tab, you can choose to access the inserted USB drive or system storage to perform 

actions such as viewing, copying, cutting, pasting, and executing batch actions. 

 Manage single file: Select a file and then press and hold the remote OK button until a pop-up menu 

appears. 

Figure 6-2 Manage single files 

 

− Copy: Example: To copy the "Alarms" folder, first bring up the pop-up menu and select Copy. 

Next, navigate to the target location where you want to paste the folder. Finally, click the Paste 

icon on the right side of the screen and wait until the process is completed. If you change your 

mind and want to cancel the paste, simply click Cancel. 
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Figure 6-3 Paste 

 

Figure 6-4 Pasting single files 

 

− Cut: The Cut operation is similar to the Copy operation. You can refer to the instructions above. 

− Delete: Bring up the pop-up menu and select Delete. 

 Batch action (batch copying and batch cutting share the similar process): First, bring up the pop-up 

menu and select Batch Action. Then, select the files you want to copy or cut. Next, click the Copy or 

Cut icon on the right side of the screen and then navigate to the target location. Finally, click the Paste 

icon on the right side of the screen and wait until the process is completed. If you change your mind 

and want to cancel the paste, simply click Cancel. 
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Figure 6-5 Manage multiple files 

 

Figure 6-6 Pasting multiple files 

 

Note 

 Only files located in the Device tab can be pasted; copying, cutting, and pasting are not avilable in 

the video, image, document, and package tabs. 

 Pasting will fail if there is insufficient storage space, and you cannot past a folder to its current 

location. 

 If the file being pasted has the same name as a file or folder in the current location, the pasted file will 

be renamed. 

 File sorting: You can sort files by file name (default), file size, or modification time. 

Note 

 Files can be sorted by file name from A to Z or Z to A, with A to Z as the default. 

 Files can be sorted by file size from small to large or large to small, with small to large as the default. 
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 Files can be sorted in ascending or descending order based on the time of modification, with 

descending order as the default. 

 To switch the sorting order, simply press the remote OK button to toggle between ascending and 

descending. 

Manage Files by Type 

Step 1 On the main screen of the system, click  to open the File Explorer interface. 

Figure 6-7 File explorer 

 

Step 2 You can view and manage files by file types. 

 In the Documents tab, you can short press the OK button on the remote to open the selected 

document, or long press the OK button to delete it. 

Figure 6-8 Documents 

 



 

TU20 Pro & TU15 Pro LED Playback 
Control Processor User Manual  

 

 www.novastar.tech   29  
 

 

 In the Videos tab, you can short press the OK button on the remote to preview the selected video, 

short press the Left or Right button to switch between videos, and double-press Return button to exit 

preview mode. Long press the OK button to delete the video. 

Figure 6-9 Videos 

 

 In Images tab, you can short press the OK button on the remote to preview the selected image, short 

press the Left or Right button to switch between images, and double-press Return button to exit 

preview mode. Long press the OK button to delete the image. 

Figure 6-10 Images 

 

 In the Packages tab, you can short press the OK button on the remote to open the selected package, 

or long press the OK button to delete it. 
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Figure 6-11 Packages 

 

7   Media Player 

Manage Media Library 

Step 1 On the main screen of the system, click  to open the Player interface. 

Step 2 Select Library from the navigation bar on the left. 

There are one video and three images pre-installed in the library by default. 

You can sort the images and videos by name, size, or time on the top right corner of the screen. 

Figure 7-1 Media Library 

 

Step 3 To import new media files, click Import, select a file, and then click OK. 
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Figure 7-2 Import 

 

Note 

You need to insert a USB drive first before you can import images and videos. 

Step 4 After selecting a media file, long press the OK button on the remote to access options such as 

renaming, bulk selection, and deletion. (System preset media is not editable by long press.) 

Figure 7-3 Library 

 

Note 

Media being used by programs cannot be deleted. 

Step 5 After selecting a media file, short press the OK button on the remote to start or pause the playback. 

Short press the Down button to bring up a menu for Playlist and Play Order 

 Playlist: Short press the Left or Right button to switch between media files and long press the buttons 

to fast forward or rewind. 

 Play Order: Press the Left or Right button to switch between Repeat List, Play Once, and Repeat One. 
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Figure 7-4 Media playback 

 

Note 

If using touch input: The menu area can be scrolled up and down or selected by a single tap; the list area 

can be swiped left or right or selected by a single tap; the function items are to be selected by a single tap 

for execution. 

Manage Program 

Step 1 On the main screen of the system, click  to open the Media Player interface. 

Step 2 Select Program from the navigation bar on the left. 

You can sort the programs by name, size, or time on the top right corner of the screen. 

Figure 7-5 Program 
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Step 3 To create a new program, click Create, select the desired media files from the library and then click OK. 

You can also select Save or Publish to save or publish the program. 

Figure 7-6 Create a program 

 

What’s more, programs can also be edited in the VNNOX app and published to the playback control 

processor. For detailed operations, please click Me > Help > User Manual in the VNNOX app and refer 

to the user manual. 

Step 4 After selecting a program, select Save or Publish from the right to save or publish the program. Long 

press the Confirm button on the remote to access options such as renaming, batch selection, and 

deletion (The default program cannot be edited). 

Figure 7-7 Program operations 

 

Step 5 After selecting a program, short press the OK button on the remote to start or pause the playback. 

Short press the Down button to bring up a menu for Playlist. 

Playlist: Short press the Left or Right button to switch between media files and long press the buttons 

to fast forward or rewind. 
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Figure 7-8 Program playback 

 

Note 

If using touch input: The menu area can be scrolled up and down or selected by a single tap; the list area 

can be swiped left or right or selected by a single tap; the function items are to be selected by a single tap 

for execution. 

Search 

Step 1 On the main screen of the system, click  to open the Media Player interface. 

Step 2 Select Search from the navigation bar on the left. 

Step 3 You can search in the Library and Program. 

Figure 7-9 Search 

 

Step 4 Input letters and numbers, and the media/programs with corresponding names will be filtered in real 

time. 
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8   Settings Management 

Network Settings 

8.1.1   Wired network 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Network > Wired Network to open the wired network interface. 

Figure 8-1 Wired network 

 

Step 3 Select Auto or Manual for the configuration mode. 

 Auto: The device automatically obtains an IP address. 

 Manual: Manually set a static IP address for the device. 

Note 

The default IP address for TU V1.6.0 and later is a static IP address: 192.168.0.10. 

8.1.2   Wireless Network 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Network > Wireless Network to open the wireless network interface. 
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Figure 8-2 Wireless network 

 

Step 3 Select an available Wi-Fi network near you and enter the password in the displayed window. 

Step 4 Press OK to connect to the Wi-Fi network. 

8.1.3   Bluetooth 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Network > Bluetooth to open the Bluetooth interface. 

Step 3 Toggle on Bluetooth. 

Figure 8-3 Bluetooth 

 

Step 4 Select a target device from Other Devices to start pairing. 

Remove the Remote 

Step 1 Select Remote from My Devices to open the remote settings interface. 

Step 2 Click Remove to forget the current remote. 
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Step 3 If you want to forget the connected remote and pair with another one, simply click Remove and then 

follow the instructions to pair with a new remote. 

Figure 8-4 Remove the remote 

 

8.1.4   Hotspot 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Network > Hotspot to open the hotspot interface. 

Step 3 Toggle the hotspot option on ( ) and set the device name, hotspot password, and channel 

information. You can also quickly connect to the device's hotspot by scanning the QR code on the right 

with your mobile phone. 

Figure 8-5 Hotspot 

 

 The device name must follow the below rules: 

− Emojis are not allowed. 
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− The name must be between 1 and 24 characters in length. 

− Only the supported characters are allowed, including: `~!@#$%^&*-_+=` 

− The device name and hotspot name are the same, and the hotspot name will automatically 

change to match any updates to the device name. 

 The password must follow the below rules: 

− The password must be between 8 and 24 characters in length. 

− Only the supported characters are allowed, including: `~!@#$%^&*-_+=` 

− The password must contain at least three of the followings: uppercase letters, lowercase letters, 

numbers, and symbols. 

Note 

 After you change the hotspot name or password, please insert the mirroring dongle into the USB port 

of the playback control processor for pairing again. 

 Please consider changing to a stronger password if your current one is weak. 

Display and Effects 

8.2.1   Effects 

To have a more comfortable viewing experience, you can adjust the display effects via the following 

methods. 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Display and Effects > Effects to open the effect adjustment interface. 

Figure 8-6 Effect adjustment 

 

Step 3 Select an effect mode according to your need. 

 Standard: Suitable for most content viewing. 
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 Meeting: Suitable for document display and providing a more comfortable viewing experience. 

 Vivid: Suitable for movie, video and image playback and delivers vibrant and pleasing effects. 

 Skin: Suitable for video meeting scenarios and guarantees accurate and natural skin tones. 

Step 4 You can fine-tune the effect parameters after selecting an effect mode to satisfy personalized 

requirements. 

1. Adjust the values for Brightness, Saturation, Contrast, Color Temperature and Hue to customize the 

display effect. 

2. (Optional) If you are not satisfied with the effect after adjustment, press the Reset button to reset the 

parameter values to the defaults. 

8.2.2   Eye Comfort 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Display and Effects > Eye Comfort to enable or disable the Eye Comfort Mode. 

The Eye Comfort Mode enables a little yellowish display on the screen to relieve eye fatigue. 

Figure 8-7 Eye comfort 

 

8.2.3   Image Enhancement 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Display and Effects > Image Enhancement. 

Step 3 Select an image quality mode Natural, Standard, Ultimate, or Off. 

The display effect can be significantly enhanced through three key factors: contrast, details, and color. 

This results in a more nuanced and vibrant image gradation, clearer and sharper edge details, as well 

as brighter and more vivid colors. 
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Figure 8-8 Image enhancement 

 

Sound Settings 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Sound to open the sound interface. 

Figure 8-9 Sound settings 

 

Step 3 You can adjust the system volume and select an Audio Output option from the following: Default Audio, 

External 3.5mm Audio, and SPDIF Audio. 

Note 

Audio output priority: external Bluetooth audio > external USB audio > SPDIF audio = external 3.5mm 

audio 
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General Settings 

8.4.1   Date and Time 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select General > Date and Time to open the date and time interface. 

Step 3 The date and time settings that are available include the following options. 

 Automatic date and time: Automatically retrieve date and time from the Internet. You can also disable 

this function and then manually set the date and time of the system. 

 24-hour format: Show the time in the 24-hour format. The system time is displayed in the 12-hour time 

format by default. 

 Date format: Set the date format to Year-Month-Day (default), Month-Day-Year or Day-Month-

Year. 

Figure 8-10 Date and time 

 

8.4.2   Language and Keyboard 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select General > Language and Keyboard to open the language and keyboard interface. 

Step 3 You can set the language and input method for the system. 

 Language: Available languages include English, Simplified Chinese, Traditional Chinese, Japanese, 

Russian, Korean, Portuguese, Spanish, and Italian. 

 Keyboard: Available options include Android keyboard (AOSP). 
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Figure 8-11 Language and keyboard 

 

8.4.3   Signal Source 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select General > Source to open the signal source interface. 

Figure 8-12 Signal source 

 

Step 3 Select a Boot Source option from the following: Android, HDMI 1, and HDMI 2. 

Step 4 Enable or disable Auto Source Switching as needed (this option is enabled by default). 

 If this option is enabled, the device will automatically redirect to a signal source upon detecting the 

signal source connection. 

 If this option is disabled, a pop-up window will appear when a signal source is connected. Select Enter 

to access the signal source. 

Step 5 (Optional) Enable or disable Signal source access exits standby (this option is disabled by default). 
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 Enabled: When the device is on standby, it will exit standby when a signal is connected. 

 Disabled: When the device is on standby, it will not exit standby when a signal is connected. 

8.4.4   Screensaver 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select General > Screensaver to open the screensaver interface. 

Step 3 Toggle on Screensaver. 

Step 4 Set a screensaver idle time. Available options are 15 minutes, 30 minutes, 1 hour. 

Step 5 Choose between Default and Custom for Screensaver Style. 

 Default screensaver displays the current date and time. 

 Custom screensaver displays any image you choose. Press the OK button to select an image and you 

can select up to 10 images. 

Step 6 Click Preview to preview the current screensaver in full screen. 
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Figure 8-13 Screensaver 

 

8.4.5   Assistive Touch 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Toggle on General > Assistive Touch to show the Assistive Touch menu on both sides of the screen. 

Press the  icon on the left and right sides of the screen to open the sidebar. 

Figure 8-14 Assistive touch 

 

 : Back button. Click to go back to the previous interface. 

 : Home button. Click to go back to the main screen. 

 : Pencil button. Click to activate the commenting tool. 

 : Signal source button. Click to display all signal sources, and you can easily switch between them. 

Options that are grayed out indicate that there is no signal available and cannot be selected. The green 

dot signifies the currently active source. 
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 : Menu button. Click to access the menu bar, which enables convenient access to various functions, 

as illustrated below. 

 

 : Whiteboard button. Click to access the whiteboard tool. 

 :  Recents button. Click to show all active or open apps, allowing you to easily find or close them. 

Note 

The remote cannot operate the assistive touch menu. You need to connect a mouse or use a touchscreen 

for control. 

Playback Settings 

8.5.1   Play Program at Startup 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Playback > Play Program at Startup to open the corresponding interface. 

Step 3 When Play Program at Startup is enabled, the program will automatically start playing when the 

device is powered on or wakes up from sleep mode. 

Step 4 Choose a program to be played. Available options include Last Played and Custom. 

 Last played: The video that was played before power-off will automatically start playing upon power-

on. 

 Custom: Click Select Program to choose a program to be played. You can only select 1 program. 
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Figure 8-15 Play program at startup 

 

Personalize 

8.6.1   Wallpaper 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Settings > Personalize > Wallpaper to open the wallpaper interface. 

Step 3 Select a wallpaper and then press the Confirm button on the remote. 

Figure 8-16 Wallpaper 

 

Step 4 (Optional) To select a custom wallpaper, select  to add wallpapers. 
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Figure 8-17 Adding custom wallpapers 

 

Note 

Before setting a custom wallpaper, ensure the image is stored on a USB drive or imported into the device's 

storage. 

System Settings 

8.7.1   About 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Settings > System> About to open the corresponding interface. 

Step 3 Click Device Name to set a name for your device. 

Step 4 Click Device Information to check the below information. 

 Version 

− Android version 

− System version 

− System version release time 

− Sending card FPGA version 

− Receiving card model 

− Receiving card MCU version 

− Receiving card FPGA version 

 Storage 

− Memory 
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− Storage 

 Status 

− Device MAC address 

Step 5 Click the Service Agreement to view the terms and conditions of this device. 

Figure 8-18 About 

 

8.7.2   Auto Standby/Wake-up 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Settings > System> Auto Standby/Wake-up to open the corresponding interface. 

Step 3 Enable Auto Standby and Auto Wake-up as needed. 

Step 4 Set the time and repeat pattern for Auto Standby and Auto Wake-up. 

Figure 8-19 Auto Standby/Wake-up 
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8.7.3   System Update 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Settings > System > System Update to open the corresponding interface. 

Figure 8-20 System update 

 

Step 3 Select Local Update or Online Update. 

 Local update: Insert the USB drive that contains the update package into the USB port of the device. 

The update package has a file extension of *.nuzip and the package must be placed in the root 

directory of the USB drive. When the screen displays "There are update packages in the root directory 

of the USB flash drive and update is available”, press the Update button. 

Figure 8-21 Local update 

 



 

TU20 Pro & TU15 Pro LED Playback 
Control Processor User Manual  

 

 www.novastar.tech   50  
 

 

Note 

The update process takes approximately 5-8 minutes. During this time, do not turn off the device, remove 

the USB drive, or use the remote control. (Turning off the power or removing the USB drive can be 

dangerous and may damage the device.) 

 Online update: The system will automatically start checking for the latest update. If a new version is 

available, click Update Now and wait for the process to finish. 

Figure 8-22 Online update 

 

Note 

 Before starting the online update, make sure you are connected to the Internet. 

 The online update consists of two stages: After detecting the latest version, click Update Now. If the 

installation package for the current version is already available locally, the system will proceed 

directly to install it. 

 Please do not exit the update process intentionally. If the update is interrupted due to a shutdown or 

power outage, the installation package will be saved locally. 

8.7.4   Factory Reset 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Settings > System > Factory Reset to open the factory reset interface. 

Step 3 Click Factory Reset to reset the device to its factory default settings. 

Factory reset will erase all the data including local documents, images, videos, applications, etc., and 

the data cannot be recovered. 
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Figure 8-23 Factory reset 

 

Note 

After factory reset, you need to perform commercial activation for the mirroring dongle again. 

8.7.5   Screen Dehumidification 

Step 1 On the main screen of the system, click  to open the settings interface. 

Step 2 Select Settings > System to open the system settings interface. 

Step 3 You can enable or disable Screen Dehumidification as need. By default, this feature is disabled, but it 

will take effect in real-time once you enable it. 

LED products are moisture-sensitive. In order to extend the service life of the screen in a relatively 

humid environment, when the device is not turned on for a period of time, it needs to be dehumidified 

before it is turned on again. 

After activating the dehumidification function, the system will begin the dehumidification process 

according to the length of time the device has been powered off. This process includes automatically 

adjusting the screen brightness and implementing aging procedures for different periods of time. The 

power-off duration of the device is calculated by subtracting the last power-down time from the 

subsequent power-up time of the device. 
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Figure 8-24 Screen dehumidification 
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