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 Change History 

Document 

Version 

Release Date Description 

V1.0.0 2024-12-16 Update Unico-related information. 

V1.0.0 2024-12-10 First release 
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 Applications 

The application diagram takes the VX2000 Pro as an example. 
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 Home Screen 

This chapter takes the VX2000 Pro as an example. 

Home Screen 

Figure 3-1 Home Screen (VX2000 Pro) 

 

No. Content Description 

1 VX2000 Pro The device name 

 
 Hold down the knob and BACK 

button simultaneously to lock or 

unlock the front panel buttons. 

 After the buttons are locked, all 

the button operations will not 

take effect and the  icon will 

appear. 

 After the buttons are unlocked, 

the  icon will disappear. 

192.168.0.10 The device IP address 

2  Layer 1 

 Layer 2 

 Layer 3 

Displays the opened layer 

information, including the layer 

number, input source, input 

resolution and frame rate 

3 1920×1080@60 Displays the resolution and frame 

rate of the configured screen. 

 The screen brightness 
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No. Content Description 

4  The Ethernet port is connected. 

 The Ethernet port is not connected. 

 
 The Ethernet port is connected 

and serves as the backup output 

port. 

 When the backup icon at the 

bottom flashes, there is data 

transmission on the port. 

5 Synchronization 

 

The sync function is enabled and the 

synchronization succeeded. 

 

The sync function is not enabled. 

 

The sync function is enabled and the 

synchronization is in progress. 

 

The sync function is enabled but the 

synchronization failed. 

Display control 

 

The output is black. 

 

The test pattern is shown. 

 

The output image is displayed. 

 

The output image is frozen. 

Connection 

method 
 The device is connected to the 

control PC via an Ethernet port. 

 The device is not connected to the 

control PC. 

 The device is connected to the 

control PC via a USB cable. 

USB insertion 

status 
 USB drive inserted. 

 No USB drive inserted. 
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Second Home Screen 

OPT Status Screen 

When the device is in Video Controller mode, this page may vary according to the device 

connected to the OPT port, as well as the OPT 3/4 working mode and the OPT loop mode. 

 When a fiber converter is connected to OPT 1/OPT 2, the port is used as an output 

connector. The OPT status page displays the connection and backup statuses of the 

Ethernet ports on the fiber converter connected to the VX2000 Pro, as shown in Figure 3-2. 

Figure 3-2 OPT Status screen 

 

 When a PIXELHUE video processor is connected to OPT 1/OPT 2, the port is used an input 

connector. The OPT status page displays the resolution and frame rate of the accessed OPT 

source and the connection and backup statuses of the Ethernet ports on the fiber converter 

connected to the VX2000 Pro, as shown in Figure 3-3. 

Figure 3-3 OPT input 

 

 When OPT loop mode is enabled, the OPT status page is shown as follows. 
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Figure 3-4 OPT Loop 

 

 

You can set the working mode of OPT 3 and OPT 4 to Copy or Backup. The OPT status screen 

page will display the set working mode. 
 

Fiber Converter Screen 

When the device working mode is set to Fiber Converter, OPT 1~4 are all used for input and 

Ethernet ports are used for output. OPT 1 and OPT 2 serve as the primary connectors, while 

OPT 3 and OPT 4 serve as backup ones. The fiber converter screen page displays the data 

transmission status of Ethernet ports on the fiber converter. 

Figure 3-5 Fiber converter screen 

 

 : There is data transmission on Ethernet port. 

 : No data transmission on Ethernet ports 
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 Menu Operations 

 

Knob: 

 On the home screen, press the knob to enter the operation menu screen. 

 On the operation menu screen, rotate the knob to select a menu item and press the knob to 

confirm the selection or enter the submenu. 

 When a menu item with parameters is selected, you can rotate the knob to adjust the 

parameters. Please note that after the adjustment, you need to press the knob again to 

confirm the adjustment. 

BACK: Exit the current menu or cancel an operation. 
 

Screen Brightness 

Screen brightness allows you to adjust the LED screen brightness in an eye-friendly way 

according to the current ambient illuminance. Besides, the brightness parameters can be saved 

to the receiving cards. 

Prerequisites 

The device is connected to a screen. 

Screen Example 

 



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 13 
 

Operating Procedure 

Step  1 On the home screen, press the knob to enter the main menu screen. 

Step  2 Select Screen Brightness and press the knob to confirm the selection. 

Step  3 Rotate the knob to adjust the brightness value. You can see the adjustment result on the LED 

screen in real time. Press the knob to apply the brightness you set when you are satisfied with 

it. 

Screen Configuration 

Screen configuration allows you to perform the following operations, including configuring the 

screen, saving configuration to the receiving card and setting output mapping. 

Figure 4-1 Screen configuration 

 

Quick Configuration 

When the LED screen is a regular one composed of cabinets from the same batch, you can use 

the quick configuration function to configure the LED screen. 

Prerequisites 

 The LED screen must be a regular one. 

 The cabinets of the screen must be regular cabinets with the same resolution. 

 The following data flow settings are supported. During data flow settings, ensure that each 

port's physical connection is along the same direction and downward to the next one. 

 During data flow settings, ensure that Ethernet Port 1 is at the beginning of the actual 

physical connection. 
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Figure 4-2 Data flow 

 

Notes 

 Cabinets loaded by Ethernet port 1 ≥ cabinets loaded by Ethernet port 2 ≥ ... ≥ cabinets 

loaded by Ethernet port n ("n" represents the maximum port number.) 

 The number of cabinets loaded by each Ethernet port must be an integer multiple of 

Cabinet Row Qty or Cabinet Column Qty of the screen. 

 The total pixels of the cabinets loaded by Ethernet port 1 cannot exceed 650,000. 

Screen Example 

 

Operating Procedure 

Step  1 On the main menu screen, rotate the knob to go to Screen Configuration > Quick 

Configuration to enter the quick configuration screen. 

Step  2 Set Cabinet Row Qty and Cabinet Column Qty according to the cabinets' actual row and 

column quantities. 

Step  3 Rotate the knob to select Port 1 Cabinet Qty to set the quantity of the cabinets loaded by 

Ethernet port 1. 

Step  4 Rotate the knob to select Data Flow (Front View) and press the knob to confirm. Select a 

physical connection for the cabinets. 
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During data flow settings, you can see the result on the LED screen in real-time. If the entire 

screen displays content correctly, that is, no overlapping or repetition, press the knob to save 

the settings. 

Save to RV Card 

After the screen configuration information is sent to the receiving card, you can save the 

configuration to the card by using this function so that the configuration data will not be lost 

after a power failure. 

Screen Example 

 

Operating Procedure 

On the main menu screen, go to Screen Configuration > Save to RV Card and press the knob 

to confirm. 

Mapping 

Mapping is used to show the relations between the cabinets of the LED screen and the sending 

devices so that you can view or check the connections between the cabinets. 

Notes 

The receiving cards that are connected to the device must support the Mapping function. For 

the supported models of the receiving cards, please visit our official website at 

www.novastar.tech. 
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Screen Example 

 

Operating Procedure 

On the main menu screen, go to Screen Configuration > Mapping and turn on the function. 

Figure 4-3 Mapping 

 

Example: S:01 stands for the sending card number, P:01 stands for the Ethernet port number 

and #001 stands for the cabinet number. 

LED Screen Color 

This function allows you to adjust the color temperature and Gamma value of the LED screen to 

make the images displayed on the screen more clear and vivid. 
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Screen Example 

 

Operating Procedure 

On the main menu screen, go to Screen Configuration > More Settings to enter the screen 

color settings screen. 

 Select Gamma and press the knob to confirm. Rotate the knob to adjust the Gamma value 

and press the knob to confirm when you are satisfied with it. 

 Rotate the knob to select Color Temperature Mode and press the knob to confirm. Rotate 

the knob to adjust the temperature mode, including Standard, Cool, Warm and Custom, 

and then press the knob to confirm when you are satisfied with it. 

When Custom is selected, you can customize the color temperature value. 

Parameter Descriptions 

Parameter Description 

Gamma Adjust the image distortion degree from the input to output. The greater the value is, 

the more distorted the image will be. 

The value ranges from 0.25 to 4.00 and defaults to 2.8. 

Color 

Temperature 

Mode 

Adjust the cool or warm degree of images displayed on the LED screen. When 

Custom is selected, you can customize the color temperature value. 
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Layer Settings 

Add Layers 

Notes 

The maximum number of layers that can be added depends on the connected device. 

Device Model Number of Supported Layers (2K×1K) 

VX2000 Pro 12 

Screen Example 

 

Operating Procedure 

Step  1 On the home screen, press the knob to enter the main menu screen. 

Step  2 Rotate the knob to select Layer Settings and press the knob to enter the layer settings screen. 

Step  3 Rotate the knob to select Layer No. and press the knob to display the layer list. 

 

 In the layer list, both the current opened layers and the layers to be opened are displayed. 

 Layer name displayed in the layer list: Opened layer: Layer n (capacity), unopened layer: Layer 

n, and “n” represents the layer number. 
 

Step  4 Rotate the knob to select the desired layer number and press the knob to confirm. 

Step  5 Rotate the knob to select Layer Status and press the knob to turn on the switch. 



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 19 
 

Step  6 Rotate the knob to select Input Source and select the desired input source for the layer. 

Step  7 Rotate the knob to select other layer parameters and set them if needed. The layer parameter 

descriptions are shown in Figure 4-4. 

Figure 4-4 Layer parameter descriptions 

 

Step  8 Rotate the knob to select Z-Order and set the layer z-order. 

The greater the priority number is, the higher priority the layer has. 

Set Layer Properties 

Parameter Descriptions 

Table 4-1 Layer properties 

Menu Description 

Layer No. The layer number 

Layer Status Open or close the layer 

 

By default, layer 1 is opened and uses the first input source. 

Input source Select an input source for the current layer. 

 

Press an input source button in the SOURCE area on the device front panel 

to quickly select an input source for the layer. 
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Menu Description 

Scaling Mode The layer supports the following three scaling modes. 

 Full Screen: The layer image fills the whole screen. 

 Pixel to Pixel: The layer image is not scaled but displayed in the original 

size of the input source or the cropped source. 

 Custom: Customize the layer size and the output image is scaled 

according to the layer size. 

H Width Set the layer size in the horizontal direction. 

The width value ranges from 64 to 131070. 

V Height Set the layer size in the vertical direction. 

The height value ranges from 64 to 131070. 

Initial X Set the horizontal distance between the top left corner of the layer and the 

top left corner of the screen. 

The value ranges from -250000 to 248080. 

Initial Y Set the vertical distance between the top left corner of the layer and the top 

left corner of the screen. 

The value ranges from -250000 to 248080. 

Z-Order The layer priority 

 Up: Bring the selected layer forward. 

 Down: Send the selected layer backward. 

 Top: Bring the selected layer to the front. 

 Bottom: Send the selected layer to the back. 

Input Crop Crop the input source image and display the cropped part on full screen. 

 Status: Turn on or turn off the function. 

 H Width: The size of the copped part in the horizontal direction 

 V Height: The size of the copped part in the vertical direction. 

 Initial X: Set the start position for the cropping in the horizontal direction. 

The value defaults to 0. 

 Initial Y: Set the start position for the cropping in the vertical direction. 

The value defaults to 0. 

3D Turn on or turn off the function. 

 On:  

 Off:  
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Input Crop 

This function allows you to crop the input source image and make the cropped part display on 

full screen. 

Prerequisites 

A fine signal is connected to the input connector. 

Notes 

 The status and capacity of the cropped source remain consistent with the original one. 

 The input cropping and 3D functions cannot be enabled at the same time. 

Screen Example 

 

Operating Procedure 

Step  1 On the home screen, press the knob to enter the main menu screen. 

Step  2 Go to Layer Settings > Input Source and press the knob to display the input source list. 

Step  3 Rotate the knob to select the desired input source and press the knob to confirm. 

Step  4 Rotate the knob to select Input Crop and press the knob to enter the input source cropping 

screen. 

Step  5 Select Status and press the knob to turn on the function. 

Step  6 Rotate the knob to configure the cropping parameters and set them if needed. The cropping 

parameter descriptions are shown in Table 4-1 and Figure 4-5. 
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Figure 4-5 Input crop effect 

 

Input Settings 

The input settings allow you to switch the input connector capacity, set input resolution and 

InfoFrame override parameters, as well as configure mosaic sources. 

Figure 4-6 Input settings 

 

Switch Connector Capacity 

Switch the input connector capacity to allow the device to calculate the number of layers that 

can be added based on the capacity. 

Prerequisites 

You have selected an input source. 
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Notes 

Changing the connector capacity of the OPT source is not supported. 

Screen Example 

 

Operating Procedure 

Step  1 On the input settings screen, rotate the knob to select Input Source and press the knob to 

display the input source list. 

Step  2 Rotate the knob to select the desired input source and press the knob to confirm. 

Step  3 Rotate the knob to select Capacity and press the knob to display the capacity list. 

Descriptions of the connector capacity: 

 SL: 1920×1080@60Hz 

 DL: 3840×1080@60Hz 

 4K: 3840×2160@60Hz 

Step  4 Rotate the knob to select the target capacity and press the knob to confirm. 

Set Input Resolution 

Set the input resolution and frame rate. The options include Standard and Custom. 

Prerequisites 

 The front-end device outputs the video source from the graphics card. 
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 You have selected an HDMI or DP source. SDI does not support this function. 

Screen Example 

Figure 4-7 Standard resolution 

 

Figure 4-8 Custom resolution 

 

Operating Procedure (Standard Res) 

Step  1 On the input settings screen, select the desired input source and press the knob to confirm. 

Step  2 On the input resolution settings screen, select Standard. 

Step  3 Rotate the knob to select Resolution, and press the knob to show the resolution list. 

Step  4 Rotate the knob to select the desired resolution from the list and then press the knob to 

confirm. 

Step  5 Rotate the knob to select the desired frame rate from the list and then press the knob to 

confirm. 

Step  6 Rotate the knob to select Apply and press the knob to complete the standard resolution 

settings. 
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Operating Procedure (Custom Res) 

Step  1 On the input settings screen, select the desired input source and press the knob to confirm. 

Step  2 On the input resolution settings screen, select Custom. 

Step  3 Rotate the knob to select Width and press the knob to confirm. Rotate the knob again to select 

the desired width and press the knob to confirm. 

Step  4 Rotate the knob to select Height and press the knob to confirm. Rotate the knob again to select 

the desired height and press the knob to confirm. 

Step  5 Rotate the knob to select Frame Rate and press the knob to show the frame list. Rotate the 

knob again to select the desired frame rate and press the knob to confirm. 

Step  6 Rotate the knob to select Apply and press the knob to complete the custom resolution settings. 

Import and Export EDID 

If you encounter a compatibility problem with an input connector, you can resolve it by 

importing a compatible EDID file into the device. You can also export an EDID file from the 

device and providing it to other devices or input connectors. 

Prerequisites 

 Before importing the EDID file, you have saved the file (.bin and .dat) to the root directory in 

an USB drive and inserted it into the device USB port. 

 Before exporting the EDID file, you have inserted an USB drive into the device USB port. 

 You have selected an accessed input source. SDI connector does support this function. 

Notes 

 Each input connector supports importing one EDID file only. 

 Once the EDID file is imported, the input connector will recognize and apply the parameters 

from the file. 
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Screen Example 

 

Operating Procedure (Import EDID) 

Step  1 On the input resolution settings screen, rotate the knob to select Import EDID and press the 

knob to enter the EDID file list screen. 

Step  2 Select the desired file and press the knob to confirm 

Step  3 In the popup dialog, select OK to import the EDID file. 

Operating Procedure (Export EDID) 

Step  1 On the input resolution settings screen, rotate the knob to select Export EDID and press the 

knob to enter the EDID file exporting screen. 

Step  2 Select the file format (.bin or .dat) and press the knob to confirm. 

Step  3 Select Apply to apply the parameters saved in the file. 

 

If you need to modify the content of an imported EDID file, just modify it and then re-import it to 

overwrite the original one. 
 

Configure InfoFrame Override Parameters 

Set the InfoFrame override parameters for the input source, allowing the device to use them 

during calculations. This won't alter the input source's original parameter values. 
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Parameter Description 

You have selected an HDMI or DP source. SDI does not support this function. 

Screen Example 

 

Operating Procedure 

Step  1 On the input settings page, rotate the knob to select InfoFrame Override and press the knob 

to enter the corresponding screen. 

Step  2 Rotate the knob to set the color/sample of the input source and press the knob to confirm. 

Step  3 Rotate the knob to set the quantization range of the input source and press the knob to 

confirm. 

Parameter Descriptions 

Menu Description 

Color/Sample The sampling format of the input 

Quantization Range The quantization range of the input 

The supported options include From Input, Limited and Full. 

 

Select From Input and the device will read the attribute values that come with 

the input source. 
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Configure Mosaic Sources 

Both HDMI and OPT sources support mosaicing. 

Notes 

 Only the VX2000 Pro supports this function. 

 Only the input sources of the same connector type support mosaicing, and the frame rates 

of sub-source must be the same. 

Screen Example 

 

Operating Procedure 

Step  1 On the input settings screen, rotate the knob to select MOSAIC and press the knob to enter the 

mosaic source settings screen. 

Step  2 Rotate the knob to select Source Type and press the knob to confirm. 

Step  3 Select the desired mosaic layout. 

Step  4 Set Width and Height for each mosaic area. 

 If the input source width or height is less than the width or height value you set, the blank 

area will be filled with solid black. 

 If the input source width or height is larger than the width or height value you set, the input 

source image will be cropped. The cropping takes the top left corner of the input source 

image as the reference point and then crops the image according to the set width and 

height values. 

 The total width and height of the mosaic source will be displayed. 
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Step  5 Rotate the knob to select the mosaic layout area and press the knob to select sub-sources of 

each mosaic area. 

Step  6 Rotate the knob to select Apply to make the settings take effect; otherwise, select Reset to 

reset the settings to defaults. 

Parameter Descriptions 

Parameter Description 

Source type The connector type of the sub sources 

The supported options include HDMI 2.0, HDMI 1.3 or OPT. 

 

Each OPT port supports transmission of 2x SL or 1x DL source. 

Layout The mosaic layout 

The layout varies depending on the source type. 

 For HDMI 2.0, three layouts are supported: " ", " " and " " 

 For HDMI 1.3, eight layouts are supported: " ", " ", " ", " ", " ", 

" ", " " and " " 

 For OPT, eight layouts are supported: " ", " ", " ", " ", " ", " ", 

" " and " " 

Width The width of the individual mosaic area 

Default value: 1920 pixels 

Height The height of the individual mosaic area 

Default value: 1080 pixels 

Mosaic Size The size of the mosaic source 

 Max. width: 8192 pixels 

 Max. height: 8192 pixels 

 Max. width and height: 4096×2160 

 

The mosaic source capacity depends on the max capacity and number of sub-sources, that is, the 

capacity of a mosaic source composed of two DL sub-sources or SL+4K sub-sources is 4K. 
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Preset Settings 

A preset is a set of parameters that save the layer and layer-related information. The VX Pro 

series supports 256 user-defined presets. After a preset is saved, you can load the preset simply 

by its name. The preset operations include Save, Load and Delete. 

Screen Example 

Figure 4-9 Preset settings 

 

Save Presets 

After the layer settings, you can save those settings as a preset. 

Screen Example 

 

Operating Procedure 

Step  1 On the preset settings screen, rotate the knob to select a preset. 
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Step  2 Press the knob to open the preset operations window. 

Step  3 Rotate the knob to select Save and press the knob to save the layer settings to this preset. 

After a preset is saved, the preset status on the right side changes to Saved. 

Load Presets 

This operation allows you to send a saved preset to an LED screen. 

Screen Example 

 

Operating Procedure 

Step  1 On the preset settings screen, rotate the knob to select a saved preset. 

Step  2 Press the knob to open the preset operations window. 

Step  3 Rotate the knob to select Load and press the knob to load the preset. 

After a preset is loaded, the preset status on the right side changes to In Use. 

 

Press the PRESET button on the front panel to quickly enter the preset setting screen. You can 

press a number button to quickly load the corresponding preset. 
 

Delete Presets 

This operation allows you to clear the data saved in the preset. The preset name will not be 

cleared. 
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Screen Example 

 

Operating Procedure 

Step  1 On the preset settings screen, rotate the knob to select a saved preset. 

Step  2 Press the knob to open the preset operations window. 

Step  3 Rotate the knob to select Delete and press the knob to open a confirmation window. 

Step  4 Rotate the knob to select Yes and press the knob to delete the preset. 

Display Control 

Notes 

If the freeze or FTB function is turned on, the test pattern function is unavailable. 

Screen Example 
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Parameter Descriptions 

Menu Sub-Menu Description 

Normal - Display the content of the current input source. 

Freeze - Freeze the current frame of the output image. 

FTB - Make the output image fade to black. 

Test Pattern Pure Color The pure color test pattern 

Gradient The gradient test pattern 

Grid The grid test pattern 

Brightness The brightness of the test pattern 

Spacing Level Set the spacing between different color areas. 

If a multi-color test pattern is selected, this parameter is 

available. 

Spacing (px) Set the spacing between the lines. 

If a grid test pattern is selected, this parameter is available. 

Line Width Set the width of the grid lines. 

If a grid test pattern is selected, this parameter is available. 

Speed Set the moving speed of the lines. 

If a grid test pattern is selected, this parameter is available. 

Output 

Color 

Brightness The shading of lights in the image 

Adjust the brightness value either as a whole or individually 

adjust the RGB components. 

Contrast The ratio of the luminance of the brightest color to that of the 

darkest color 

Adjust the contrast value either as a whole or individually adjust 

the RGB components. 

Saturation The color purity of the image 

The higher the value, the more vivid the color. 

Hue The relative degree of how bright or dark the image is 
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USB Playback 

Play images or videos saved in a USB drive and configure the playback parameters. A USB 

source can be used as a layer source. 

The models of devices that support USB playback and the corresponding output resolutions for 

USB sources are listed below. 

Device Model USB Source Resolution 

VX2000 Pro 3840×2160@60Hz 

 

Press the desired layer button in the LAYER area on the device front panel and then press the U-

DISK button to use a USB source to open a layer. 
 

USB Player 

Prerequisites 

A USB drive has been inserted and recognized in the U-DISK connector on the front panel. 

Notes 

Up to 128 files can be displayed in the playlist and the size of each file cannot exceed 128 GB. 

Screen Example 
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Operating Procedure 

Step  1 On the main menu screen, go to USB Playback > USB Player to enter the USB player screen. 

Step  2 Rotate the knob to select the desired the file and press the knob to play the file or stop the 

playback. 

The items displayed on this screen are as follows. 

 Media files in compatible formats 

 The playback mode 

 The playback status 

 The volume level 

Playback Settings 

Configure the playback-related parameters. 

Screen Example 

 

Limitations 

 Single-partition USB drive supported 

 File system: NTFS, FAT32 and exFAT 

 Max. width and height of media files 

Width: 3840 pixels, height: 2160 pixels 

 Picture format: jpg, jpeg, png and bmp 

 Decoded image resolution: 3840×2160 or lower 
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 Video format: mp4 

 Video coding: H.264, H.265 

 Max. video frame rate: 

H.264: 3840×2160@30fps, H.265: 3840×2160@60fps 

 Audio coding: AAC-LC 

 Audio sampling rate: 8kHz, 16kHz, 44.1kHz, 48kHz 

Parameter Descriptions 

Parameter Description 

Playback Mode The playback mode of the file 

 Loop: Play the files in the playlist in order. Once the playback of the last file 

is completed, replay the first file. 

 Play in Order: Play the files in the playlist in order. Once the playback of the 

last file is completed, the screen will display a black image and the playback 

will stop. 

 Repeat One: Loop playback of the current file. 

File Type The type of the playback file 

 Video 

 Image 

 All: Video and Image 

 

After the file type is selected, only the file of the selected type will be displayed 

in the playlist. 

Image Playback 

Duration (s) 

The duration of the image playback 

The value ranges from 1 to 60 and it defaults to 5. (Unit: s) 

Image Transition 

Effect 

The trans effect of the image 

Supported trans effect: Ripple, zoom in, push, flip, blinds, H wipe, V wipe, 

cube, dissolve, grid, swapping, scroll, fade in/out, twirl, heart trans, curtains, 

perspective triangle, disappear, bounce, star rotation 

Image Trans Duration 

(s) 

The trans duration of the image 

The value ranges from 0.5 to 2 and it defaults to 0.5. (Unit: s) 

Auto Playback Set whether to automatically play the USB files after the device is powered off 

and then power on with a USB drive inserted. 
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Parameter Description 

 : On 

If Resume Playback not enabled, replay the files in the playlist in order; If 

enabled, replay the file being played before power failure from the 

beginning. 

 : Off 

Resume Playback  On: If a file is playing before the device power failure, enabling this function 

allows to replay the file from beginning after the device is powered on with 

a USB drive inserted. 

 Off: Replay the files in the playlist in order. 

 

 Enabling Resume Playback will also activate the Auto Playback feature at 

the same time. 

 After Resume Playback is enabled, if the file being played before power 

failure cannot be found, the files will be played from the beginning of the 

playlist in order. 

Advanced Settings 

End-to-End Backup 

The end-to-end backup is supported, including device backup, input source backup and 

Ethernet port backup test, stable and reliable. 

Device Backup 

The backup between devices and Ethernet ports are both supported. 

4.8.1.1.1   Backup Between Devices 

Device backup allows you to set the backup relationship between two devices. You can set one 

of the devices as the primary device or the backup device. When the primary device has a 

problem or the primary device's Ethernet cable fails, the backup device will take over the 

responsibilities of the primary device seamlessly and continue to work well to ensure the LED 

screen will not go black. 
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Prerequisites 

 Before creating a backup relation, make sure that both the primary and backup devices are 

on the same LAN. 

 In a backup relation, the models and device versions of the primary and backup devices must 

be the same. 

Notes 

 You have three options to create a backup relation: NovaLCT, Unico web page, or the device 

LCD menu. However, be aware that these methods do not synchronize with each other. 

Using more than one can lead to data problems. To prevent issues, choose only one method 

for setting up your backup. If you do mix them, you'll need to reset the device to factory 

settings and start over with just one method. 

 In the device backup mode, the quantity of the cabinets loaded by each Ethernet port on 

both the primary and backup devices must be the same, but their data flow must be in a 

reversed way. 

Hardware Connections 

The diagram takes the VX2000 Pro as an example. 
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Screen Example 

 

Operating Procedure 

Step  1 On the main menu screen, go to Advanced Settings > End-to-End Backup > Device Backup to 

enter the device backup screen. 

The available devices on the same LAN will be automatically searched. 

Step  2 Set the primary device. 

Step  3 Rotate the knob to select Backup IP and press the knob to display the backup IP list. Select the 

desired IP address of a device to be set as a backup one. 

 

After a backup relation is created, the configuration parameters (except communication settings) 

of the primary device will be automatically synchronized to the backup device. 
 

4.8.1.1.2   Backup Between Ethernet Ports 

Ethernet port backup allows you to set the backup relationship between two Ethernet ports. 

When the primary port has a problem or the primary port's Ethernet cable fails, the backup port 

will take over the responsibilities of the primary port seamlessly and continue to work well to 

ensure the LED screen will not go black. When setting the backup between the Ethernet ports, 

you need to complete it in NovaLCT. 

Hardware Connections 

This diagram takes the VX2000 Pro as an example. 
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Operating Procedure 

Step  1 Run the NovaLCT software. On the menu bar, go to User > Advanced Synchronous System 

User Login. Enter the password and click Login. 

Step  2 Click Screen Configuration to enter the screen configuration page. 

Step  3 Click Next to enter the screen configuration page. 

Figure 4-10 Screen configuration 

 

Step  4 Select the Sending Card tab, and then click Add in the Redundancy area. 
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Step  5 Set the serial numbers of both the primary device and backup device to 1. 

Step  6 Set the serial number of the primary port and the serial number of the corresponding backup 

port. 

Figure 4-11 Ethernet port backup 

 

Step  7 Click Add to complete the backup settings of an Ethernet port, and the system will 

automatically list the primary ports and backup ports. 

Figure 4-12 Primary Ethernet ports 

 

Step  8 Repeat Step  6 and Step  7 to complete the backup settings for other Ethernet ports. 

Input Backup 

Input backup allows you to set the backup relationship between two input sources. When one 

input source has a problem or the input connector fails, the backup source will be used 

seamlessly and continue to work well to ensure the LED screen will not go black. 
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Notes 

Input backup rules: 

 In each backup group, two input sources serve as the backup for each other. 

 Only the source from the same type of input connector can be set as the backup source. 

 Each primary or backup source can have only one backup or primary source. 

 Restrictions on input backup functions: 

Input sources A and B form a hot backup group. The current input source of the layer is 

input source A. 

− Input A: No signal. Input B: Signal 

The layer input source is switched to input B automatically. When input A resumes and 

input B still has a signal and Primary Source Preferred is not enabled, the layer input 

source will not be changed. 

− Input A: No signal. Input B: Signal 

The layer input source is switched to input B automatically. When input A resumes, but 

input B does not have a signal, the layer input source will be changed to input A. 

− Input A: No signal. Input B: No signal 

The layer input source will not be changed. 

− Input A: Signal. Input B: No signal 

If you manually switch the layer input source to input B, the source will automatically 

switch to input A. 

Screen Example 
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Operating Procedure 

Step  1 On the main menu screen, go to Advanced Settings > End-to-End Backup > Input Backup to 

enter the input backup settings screen. 

Step  2 Rotate the knob to select Input Backup and press the knob to turn on the function. 

Step  3 Rotate the knob to select the desired primary input source on the left side. 

Step  4 Rotate the knob to select the desired backup input source on the right side. 

Step  5 (Optional) Set the primary source preferred. 

 On: The primary source will always be used if there is a signal. When the primary source fails, 

the layer input source is switched to the backup one automatically. Once the primary source 

resumes, the layer input source seamlessly switches back to the primary source. 

 Off: The layer input source will be switched to the primary source only when the backup one 

fails and the primary one has a signal. 

Ethernet Port Backup Test 

Test whether the pre-stored images, backup Ethernet ports and devices take effect without 

plugging and unplugging the Ethernet cables. 

Prerequisites 

The pre-stored images, primary and backup Ethernet ports or primary and backup devices have 

been configured. 

Screen Example 
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Parameter Descriptions 

Parameter Description 

Off Enable the output of all the Ethernet ports on the current device to 

complete the test. 

Backup Only Disable the output of the primary Ethernet port on the current device to test 

whether the backup port or device takes effect. 

Primary Only Disable the output of the backup Ethernet port on the current device to test 

whether the output of the primary port is normal. 

Disconnect All: Disable the output of all the Ethernet ports on the current device to test 

whether the pre-stored image takes effect. 

Synchronization 

This function allows you to select a synchronization signal to synchronize all the cascaded 

device units or synchronize the primary and backup devices to display the output images of all 

the units in sync. 

Notes 

 The input source with or without signal can be used as a sync source. When a no signal 

source is used, the sync fails. 

 Synchronizing to a DP source is supported by the VX2000 Pro only. 

 Before enabling the Genlock sync function, make sure the sync signal has been connected to 

the Genlock connector of the device. 

Screen Example 
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Operating Procedure 

Step  1 On the main menu screen, go to Advanced Settings > Synchronization to enter the 

synchronization settings screen. 

Step  2 Rotate the knob to select Sync To and press the knob to display the sync source list. The 

options include Internal, HDMI X/DP/SDI and Genlock. ("X" represents the input source 

number and its format may vary depending on the actual setup.) 

 Internal: The frame rate of the output image 

 HDMI X/DP/SDI: Sync with the frame rate of the selected input source. After a sync source is 

selected, the sync frame rate will be displayed. 

 Genlock: Sync with the frame rate of the Genlock signal. 

Step  3 (Optical) If Internal is selected, you can manually set the output frame that defaults to 60Hz. 

Once the synchronization is successful, the screen will show Succeeded. 

Audio Settings 

This function allows you to set the audio status, output audio and volume. 

Hardware Connections 

The diagram takes the VX2000 Pro as an example. 

 Via a multifunction card 

Connect the Ethernet port 1 or 2 to a multifunction card, and then connect the multifunction 

card to an external speaker. 
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 Via the audio output connector 

Connect the audio output connector to an external speaker. 

 

Screen Example 
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Set Audio Status 

Turn on or turn off the audio, and adjust the output and volume settings as needed. 

Screen Example 

 

Operating Procedure 

Step  1 On the main menu screen, go to Advanced Settings > Audio to enter the audio settings screen. 

Step  2 Rotate the knob to select Status and press the knob to confirm. 

Step  3 Rotate the knob to select On or Mute to turn on or turn off the audio. 

Select Output Audio 

Set to play which audio on the external audio. 

Notes 

Only the VX2000 Pro supports output of the accompanied audio that comes from a DP 

connector. 
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Screen Example 

 

Operating Procedure 

Step  1 On the main menu screen, go to Advanced Settings > Audio > Output and press the knob to 

display the output audio list. 

Step  2 Select the desired output audio and press the knob to confirm. 

 AUDIO IN: Output the analog audio that comes from an external audio device. 

 HDMI: Output the accompanied audio that comes from an HDMI connector. 

 DP: Output the accompanied audio that comes from a DP connector. 

 U-DISK: Output the audio of a USB source. 

Set Output Volume 

Adjust the output volume. 

Screen Example 
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Operating Procedure 

Step  1 On the main menu screen, go to Advanced Settings > Audio to enter the audio settings screen. 

Step  2 Rotate the knob to select Volume and press the knob to confirm. Then rotate the knob again to 

adjust the audio volume and press the knob to confirm. 

Parameter Descriptions 

Parameter Description 

Volume The output volume 

The value ranges from 0 (silent) to 100 (loudest) and defaults to 50. 

Low Latency 

When the input source travels from where it comes to the processing device, sending device 

and then the receiving card, latency exists inevitably. Turning on this function can effectively 

help to reduce the latency from the input to output. 

Notes 

To enable low latency, please make sure all Ethernet ports load the cabinets vertically and share 

the same Y coordinate. Free screen configuration (for example, Ethernet port 2 loads cabinets 

horizontally, or its Y coordinate is different from that of Ethernet port 1) will reduce the load 

capacity. 
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Operating Procedure 

On the main menu screen, go to Advanced Settings > Low Latency and press the knob to 

confirm. Then rotate the knob again to turn on or turn off the function and press the knob to 

confirm. 

3D 

Directly connect a third-party 3D emitter using the device's built-in 3D connector, or connect to 

the EMT200 emitter via the device's Ethernet port. Then, use the compatible 3D glasses to 

achieve a 3D display effect. 

Prerequisites 

 Video source format: Side-by side, top-and-bottom or frame sequential 

 When paired with the EMT200, it is recommended to use a 3D source of 60Hz to enjoy an 

optimal experience. 

Notes 

 Enabling the 3D function will halve the device output capacity. 

 The 3D function and input cropping cannot be enabled at the same time. 

 After enabling the 3D function on the advanced settings screen, 3D switches of all the layers 

will be toggled on. If you want to use a 2D layer, please toggle off the 3D switch of the 

desired layer on the layer settings screen. 

 The 3D effect follows the layer. The output area where a 3D layer is located always displays 

the 3D effect. 

Hardware Connections 

The diagram takes the VX2000 Pro as an example. 
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Screen Example 

 

Operating Procedure 

Step  1 On the main menu screen, go to Advanced Settings > 3D Settings > Status to turn on the 

function. 

Step  2 Select the 3D format of the video source. The options include Side-by-Side, Top-and-Bottom 

and Frame Sequential. 

Step  3 Set the eye priority. The options include Left and Right. 

Step  4 (Optional) Turn on the Enable Third-Party Emitter switch. 

Step  5 Set the signal delay duration. 

The value ranges from 0 to 20000 and defaults to 7000. (Step: 1, unit: us) 
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Working Mode 

Setting device and OPT wording modes are both supported. 

Device Working Mode 

Three working modes are supported, including Video Controller, Fiber Converter and ByPass. 

Screen Example 

 

Parameter Descriptions 

Device Model Parameter Description 

VX2000 Pro Fiber Converter Optical fiber ports are used for input, and Ethernet ports are 

used for output. 

 OPT 1~4 are used for input, and Ethernet ports are used 

for output. 

 OPT 1 and OPT 2 serve as the primary connectors. The 

Ethernet ports 1~10 transmit OPT 1 data, and Ethernet 

ports 11~20 transmit OPT 2 data. 

 OPT 3 and OPT 4 serve as the backup connectors. 

VX2000 Pro Video Controller  OPT 1 and OPT 2 can be used as an input or output 

connector depending on the connected devices. 

 OPT 1 and OPT 2 send the output on Ethernet ports 1~10 

and 11~20 respectively. OPT 3 and OPT 4 copy or back up 

the output on Ethernet ports 1~10 and 11~20 respectively. 

VX2000 Pro ByPass Under this mode, the device works as an independent 

controller with no support for video processing functions. 
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OPT Mode 

Supports settings of both the OPT working mode and loop mode. 

Screen Example 

 

Hardware Connections 

The diagram takes the VX2000 Pro as an example. 

Figure 4-13 Copy mode 
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Figure 4-14 Backup between Ethernet and OPT ports 

 

Figure 4-15 OPT loop mode 

 

Parameter Descriptions 

Device Model Parameter Description 

VX2000 Pro OPT 3/4  Copy: OPT 3 copies the output on Ethernet ports 1~10, 

and OPT 4 copies the output on Ethernet ports 11~20. 

 Backup: OPT 3 backs up the output on Ethernet ports 

1~10, and OPT 4 backs up the output on Ethernet ports 

11~20. 

VX2000 Pro OPT Loop Loop out the video signal accessed by OPT 1 via OPT 2 for 

device mosaic. 
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Device Model Parameter Description 

 : Enable the loop mode. 

 : Disable the loop mode. 

HDCP Status 

High-bandwidth Digital Content Protection (HDCP) is a form of digital copy protection to 

prevent copying of digital audio and video content as it travels across connections. When the 

accessed input source is an HDCP-encrypted one, you need to turn on this function to enable 

the device to transmit and process the source. 

Parameter Descriptions 

Parameter Description 

HDCP Status Turn on or turn off the function. 

 : On 

 : Off 

Monitor Settings 

Real-time display of the output image via the monitor connected is supported. You can monitor 

whether the output is normal and adjust the display ratio of the monitoring image on the 

monitor to avoid image distortion. 

Notes 

The output resolution of the monitor connector is fixed at 1920×1080@60Hz. 

Parameter Descriptions 

Parameter Description 

Monitor Settings The options include Keep Ratio and Full Screen (default). 

 Keep Ratio: Keep the ratio of the original output image to display. 

 Full Screen: Display the output image in full screen. 
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Parameter Description 

When Keep Ratio is selected, the blank area that the output image cannot 

cover the entire monitor screen will be automatically filled with solid black. 

System Settings 

Fn 

This function allows you to set a shortcut button for an assigned function. By using the Fn 

button, you can quickly navigate to the target menu screen and never need to access a 

specified menu item by entering the menus level by level. 

Screen Example 

 

Operating Procedure 

Step  1 On the main menu screen, go to System Settings > Fn press the knob to enter the Fn button 

settings screen. 

Step  2 Rotate the knob to select the desired function and press the knob to confirm. 

Return to Home 

Operating Procedure 

Step  1 On the main menu screen, go to System Settings > Return to Home and press the knob to 

confirm. 
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Step  2 Rotate the knob to select the desired time value and press the knob to confirm. 

Parameter Descriptions 

Parameter Description 

Return to Home You can set the period when the system stays at the current screen before 

returning to the homepage automatically when there is no operation 

performed. 

The value ranges from 60s to 3600s 

Diagnostics 

The diagnostics function helps you to diagnose the system and troubleshoot the malfunctioned 

device components. When the device fails, you can run the diagnostics function to test the 

device. You can send your test to our technical support staff for problem locating and 

processing. For daily maintenance, you can run the diagnostics function to do the routine health 

check for the system. 

Notes 

Running diagnostics will transiently disrupt the output, and the output will resume after the 

diagnostics are completed. 

Operating Procedure 

Step  1 On the main menu screen, go to System Settings > Diagnostics and press the knob to enter 

the diagnostics screen. 

Step  2 Rotate the knob to select Run Diagnostics and press the knob to confirm, 

Step  3 In the popup dialog, rotate the knob and select Yes and press the knob to confirm. 

Export Logs 

Export the device logs to a USB drive to quickly identify issues. 
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Prerequisites 

Before exporting logs, you have inserted a USB drive into the USB port on the device. 

Operating Procedure 

Step  1 On the main menu screen, go to System Settings > Log Export to enter the log exporting 

screen. 

Step  2 Rotate the knob to select Apply and press the knob to confirm. The log file will be exported to 

the root directory of the USB drive. 

Update Device 

Import the update file saved in a USB drive to the device for quick update. 

Notes 

During the update process, power-off and all operations are NOT allowed. 

Operating Procedure 

Step  1 On the main menu screen, go to System Settings > Update to enter the device update screen. 

Step  2 Rotate the knob to select the update file and press the knob to confirm. 

Step  3 In the popup dialog box, rotate the knob to select OK and press the knob to confirm. Then wait 

for the device to automatically complete the update. 

Cascading ID 

Set the device cascading ID which is the unique identification when the device is in a cascading 

link. 

Notes 

 The cascading ID defaults to 1 and can be changed manually. You need to set an ID for each 

cascading device in order. 



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 59 
 

 After you set IDs successfully, connect devices using Ethernet cables based on the set ID. 

Parameters Description 

Parameter Description 

Cascading ID When multiple devices are cascaded, you need to set a virtual ID for each 

device, ensuring that the devices displayed in NovaLCT match with actual 

devices. 

About Us 

Under this menu item, you can view the firmware version, device SN, official website and email 

address. On our official website, you can check the latest device information and the updates 

for this device. You can also send your feedback or suggestion to us for improvements via the 

supplied email address. 

Screen Example 

 

Factory Reset 

Factory reset function allows you to reset all the parameter settings of the device to factory 

defaults after the device update or when you think the parameters are improperly set. 
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Screen Example 

 

Parameter Descriptions 

Parameter Description 

Keep User Data Reset the parameter settings to factory defaults, except for the Input EDID, 

communication, Fn, imported files and device name. 

Reset All Reset all the parameter settings to factory defaults. 

Communication Settings 

You can set the communication and network information to enable the device to communicate 

with the control PC smoothly. 

Screen Example 
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Operating Procedure 

Step  1 On the main menu screen, rotate the knob to select Communication and press the knob to 

enter the communication settings screen. 

Step  2 Select Network Mode and press the knob to confirm. 

The options include Manual and Automatic. 

 Manual: Set the device IP address, subnet mask and gateway manually. 

 Automatic: The system automatically assigns an IP address for the device. When the device 

and control PC are connected to the same router or switch, set this option to Automatic. 

Step  3 When the Manual option is selected, you must manually set the device IP address, subnet mask 

and gateway. 

Step  4 Rotate the knob to select Apply to make the settings take effect; otherwise, select Reset to 

reset the settings to defaults. 

Language 

The language options include English and Simplified Chinese. You can switch to your preferred 

language. 
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 Web Page Control 

Connection 

The control computer can connect to the device in the following two ways: 

 Via Ethernet cable 

Connect the device and the control PC directly via Ethernet cable and set a static IP address 

for the device to let it and the control PC be on the same network segment. 

 Via LAN 

Connect the device and the control PC to the same LAN to ensure that both of them are on 

the same network segment. 

Enter Web Control Page 

Prerequisites 

You have completed the connection between the device and control PC. 

Notes 

When the device is connected directly to a control PC via an Ethernet cable, the device and 

control PC must be on the same network segment and their IP addresses cannot conflict. For 

example, if the device IP address is 192.168.0.10, the IP address of the control PC must be 

192.168.0.X and X cannot be 10. 

Description 

Enter the device IP address into your browser's address bar and press Enter. The web page 

appears. 
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Project Management 

Create, edit and delete projects, and view project details. The project file (.uprj) can be exported 

by a device, and then imported into other devices of the same model, so as to quickly apply the 

device parameters and resource files in the project file. 

Create New Projects 

All the online devices on the same LAN will be automatically added to a default project. Users 

can create a new project and remove the desired device from the default project to the new 

one. 

Step  1 Select Projects on the left side of the interface to show the project list. 

Figure 5-1 Project list 

 

Step  2 Click New Project on the Online Projects tab interface. 
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Figure 5-2 Create online projects (VX2000 Pro) 

 

Step  3 Name the project. 

Step  4 Select the devices that you want to include in the project, and click Add. 

 

A device can be added to one project only. 
 

Related operations are as follows: 

 Remove: Withdraw the selected devices in Selected Devices list to Device List. 

 Add All: Add all the devices in Device List to Selected Devices list. 

 Remove All: Withdraw all the devices in Selected Devices list to Device List. 

Step  5 After the settings, click OK. 

After a project is successfully created, you will enter the device configuration interface. 

 

In the project list area, you can perform the following project-related operations: 

 Rename project: Hover the mouse over the desired project and click  that appears on the 

right side of the project name. 

 Enter project: Click Enter in the Action column. 

 Edit project: Click Edit in the Action column. 
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 Delete project: Click Delete in the Action column. 

 View project details: Click Details in the Action column. 
 

Import Projects 

Import the local project files (.uprj) to the device. Please note that the device models must 

match with the models in the project file. 

Step  1 Select Projects on the left side of the interface to show the project list. 

Step  2 Click Import Project or go to File > Import. 

Step  3 In the dialog box that appears, select a project file (.uprj) and click OK. 

Step  4 In the displayed Import Project File window, select Online Projects. 

Figure 5-3 Import project files 

 

Step  5 After successful device matching, select the data to be imported and click OK. 

The system matches the SN, name, IP address, model, and firmware version from the file with 

the online device. 

Click  and select other online devices from the drop-down menu. 
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Export Projects 

Export the device project files to your local computer. 

Step  1 Select Projects on the left side of the interface to show the project list. 

Step  2 Select the Online Projects tab, double-click the project name or click Enter in the Action 

column to enter the device configuration interface. 

Step  3 In the menu bar, select File > Export. 

Step  4 In the displayed dialog box, select the desired data. 

Figure 5-4 Export project files 

 

Step  5 Click Export. 

Step  6 In the displayed dialog box, select a file path and click Save. 

Device Management 

Enter Device Configuration Page 

Online Devices 

Step  1 Select Devices on the left side of the interface to show the device list. 
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Figure 5-5 Online device list (VX2000 Pro) 

 

Step  2 (Optional) Switch the display style of the device list as desired. 

 : Graphical view 

− View the device name, IP address and model. 

− Double clicking the device front panel image allows you to access the device 

configuration interface. 

 

 : List view 

− View the device name, IP address, model, and the project the device belongs to. 

− In the Action column, you can access the device configuration interface. 

− Place the mouse over the device information and click  that appears on the right 

side of the device name to change the device name. 

 

Step  3 Perform either of the following actions to enter the device configuration page. 

 In the graphic view mode ( ), double click the image of the device front panel. 

 In the list view mode ( ), click Enter in the Action column. 
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Configure Device Properties 

Select the device on the left side of the device configuration interface, and then configure the 

device-related properties on the right pane. 

Figure 5-6 Device properties (VX2000 Pro) 

 

Rename Device 

Change the device name. 

Prerequisites 

None 

Notes 

None 
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Interface Example 

 

Description 

Enter a name for the device in the text box next to Device Name. 

 

In the device list on the left side of the interface, you can also right click the device name and 

select Rename from the context menu to change the device name as well. 
 

Switch Working Mode 

Switch the device working mode. 

Prerequisites 

None 

Notes 

Set the device working mode according to the on-site application and screen connections. 

Interface Example 
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Description 

Select Video Controller, Fiber Converter or ByPass from the drop-down list. 

Configure IP Address 

Manually set a static IP address for the device or let the device to automatically obtain an IP 

address. 

Prerequisites 

None 

Notes 

None 

Interface Example 

 

Description 

Configure the following parameters and click Apply to make the settings take effect. 

Parameter Description 

Network Mode Select the IP configuration method. 

 Manual: Manually set a static IP address for the device. 

 DHCP: The device automatically obtains an IP address. 

IP Address The device IP address 

Subnet Mask The subnet mask of the IP address 
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Parameter Description 

Gateway The default gateway 

Configure Sync Source 

Select a sync signal to synchronize all the cascaded device units or synchronize the primary and 

backup devices to display the output images of all the units in sync. 

Prerequisites 

Before enabling the Genlock sync function, make sure the sync signal has been connected to 

the Genlock connector of the device. 

Note 

None 

Interface Example 

 

Description 

Parameter Description 

Sync To Select a sync source. 

 Internal Frame Rate: The frame rate of the output image 

 DP/HDMI X/SDI: Sync with the frame rate of the selected input source. 

"X" represents the input source number and its format may vary depending on 

the actual setup. 

 Genlock: Sync with the frame rate of the Genlock signal. 

When the function is enabled, the frame rate of the sync source will be displayed. 

Frame Rate When you select Internal Frame Rate, you can manually set the output frame 
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Parameter Description 

rate. The default value is 60Hz. 

Configure HDCP 

High-bandwidth Digital Content Protection (HDCP) is a form of digital copy protection to 

prevent copying of digital audio and video content as it travels across connections. When the 

accessed input source is an HDCP-encrypted one, you need to turn on this function to enable 

the device to transmit and process the source. 

Prerequisites 

None 

Notes 

None 

Interface Example 

 

Description 

Parameter Description 

HDCP Turn on or turn off the function. 

 : On 

 : Off 

Configure Date and Time 

Configure the time zone, date and time of the device. 
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Prerequisites 

None 

Notes 

None 

Interface Example 

 

Description 

Click Edit and the parameters become editable. Set the time zone, date and time respectively, 

and then click Apply. 

Configure Input Source Backup 

Establish a backup relation for two input sources. 

Prerequisites 

None 

Notes 

 The backup relation can only be established if the input connectors have identical capacities. 

 Once the function is enabled, the switching of the connector capacity is not supported. 

 In the Manual mode, use the designated source only regardless of signal availability. In the 

Auto mode, adhere to the following principles when the primary source transitions from no 

signal to signal presence: 
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− If Primary Source Preferred is selected, automatically switch to the primary source. 

− If Primary Source Preferred is not selected, continue using the backup source. 

Interface Example 

 

Description 

Step  1 Set the Input Source Backup switch to . 

Step  2 Select or deselect Primary Source Preferred. 

Step  3 Click . 

Step  4 Select a primary source and a backup source respectively from two drop-down lists to establish 

a hot backup pair. 

The green dot  indicates the source is accessed normally and ready for use. 

 To delete a hot backup pair, click  next to the pair and click Delete. 

 To delete all hot backup pairs, click . 

Step  5 Click  on the right and set Mode to either Auto or Manual. 

If Manual is selected, you will also need to choose the desired source. 

Reset to Factory Settings 

Reset the device data and settings to factory default values. 

Prerequisites 

None 
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Notes 

 Please do this with great caution. 

 The reset action does not affect the device firmware version. 

 Power-off is not allowed during the reset process. 

 The device will restart automatically after the reset is completed. 

Interface Example 

 

Description 

Select Keep user data or Reset all, and then click Apply. 

 Keep user data 

Retain the device IP address, input connector EDID, gallery files, language settings, device 

name and belonged project. 

 Reset all 

Retain the device IP address and belonged project. 

Restart Device 

Restart the device. 

Prerequisites 

None 

Notes 

None 
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Interface Example 

 

Description 

Click Restart, and then click Yes in the displayed dialog box. 

Configure Input Properties 

Click the target input connector on the graphical device rear panel, and then set the input-

related properties in the property area on the right pane. 

Figure 5-7 Input properties (VX2000 Pro) 

 

View Input Source Info 

View the basic properties of the input connector and change the input connector name. 

Prerequisites 

A fine signal is connected to the input connector. 
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Notes 

None 

Interface Example 

 

Description 

On the Basic tab interface, change the connector name as required. 

Set OPT Ports 

Set the OPT working mode and loop mode. 

Prerequisites 

The device working mode is set to Video Controller. 

Notes 

None 

Interface Example 
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Description 

Device Model Parameter Description 

VX2000 Pro OPT 3/4 Working 

Mode 

OPT 3 and OPT 4 working modes 

Config method: Select Copy or Backup from the drop-down 

list. 

 Copy: OPT 3 and OPT 4 copy the output on Ethernet port 

1~10 and 11~20 respectively. 

After you complete the settings, the OPT ports on the 

graphical device panel will be highlighted. 

 Backup: OPT 3 and OPT 4 back up the output on Ethernet 

port 1~10 and 11~20 respectively. 

After you complete the settings, the backup icons will be 

displayed at the bottom right corner of the OPT ports on 

the graphical device panel. 

VX2000 Pro OPT LOOP Mode Turn on or turn off the function. 

 On:  

After this function is enabled, the video signal accessed 

by OPT 1 will be looped out via OPT 2. 

 Off:  

View OPT Source Info 

View the basic properties of the OPT source and change the OPT port name. 

Prerequisites 

 The device working mode is set to Video Controller. 

 OPT 1 and OPT 2 is connected to the OPT ports on the front-end video processor via optical 

fiber cables. Additionally, a fine signal is connected to the front-end device. 

Notes 

Each OPT support the transmission of 1x DL or 2x SL sources. 
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Interface Example 

 

Description 

On the Input Source tab interface, change the connector name as required. 

Set Input Connector Capacity 

Switch the input connector capacity as desired. 

Prerequisites 

Notes 

Interface Example 

When a connector is configured for hot backup, you can no longer switch its capacity. 

Interface Example 
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Description 

Parameter Description 

Capacity Select the desired connector capacity from the drop-down list. 

 4K: 4K×2K 

 DL: 4K×1K 

 SL: 2K×1K 

Configure InfoFrame Override Parameters 

Configure the InfoFrame override parameters of the input source, so that the device can use it 

when doing some calculations. This action does not change the parameter values that come 

with the input source. 

Prerequisites 

None 

Notes 

None 

Interface Example 

 

Description 

On the Basic tab interface, configure the following parameters. 

Parameter Description 

Color/Sample The sampling format of the input 



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 81 
 

Parameter Description 

Bit Depth The bit depth of the input, i.e., the binary digits to represent a single color 

Quantization 

Range 

The quantization range of the input 

Select From Input and the device will read the attribute values that come with the input source. 

Configure EDID 

Configure the resolution and frame rate of the input. You can select the standard resolution 

provided by the device, customize a resolution, or set the advanced parameters. 

Prerequisites 

 SDI does not support this function. 

 The front-end device outputs the video source from the graphics card. 

Notes 

It is recommended the advanced settings be carried out by the trained personnel only. 
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Interface Example 

 

Description 

On the EDID tab interface, configure the following parameters and click Apply after the 

settings. 

Parameter Sub-Parameter Description 

Resolution - The number of horizontal pixels and vertical pixels of the image 

Config method: 

 Select the desired resolution from the drop-down list. 

 Select Custom from the drop-down list, and then set the width 

and height values respectively. 

Frame 

Rate 

- The image frames every second (unit: Hz) 

Config method: Select the standard common frame rates from the 

drop-down options. The available frame rates may vary according 

to the chosen resolution. 

Advanced H Total Total pixel count per line 



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 83 
 

Parameter Sub-Parameter Description 

H Active The horizontal size in pixels of the active area 

H Front Porch The offset between the end of the active area and the beginning 

of the H sync 

H Sync The horizontal sync width in pixels (or between pixels) 

H Polarity The polarity of the horizontal sync pulse 

V Total Total pixel count per column 

V Active The vertical size in pixels of the active area 

V Front Porch The offset in lines between the end of the active output area and 

the beginning of V sync 

V Sync The vertical sync width in rows (or between rows) 

V Polarity The polarity of the vertical sync pulse 

Import and Export EDID 

When compatibility problem occurs on an input connector, import an intact EDID file into the 

device; or export an EDID file from a device and provide the EDID file to other devices or input 

connectors to solve the compatibility issues. 

Prerequisites 

SDI does not support this function. 

Notes 

 Each input connector supports importing one EDID file only. 

 Once the EDID file is imported, the input connector will recognize and apply the parameters 

from the file. 

Interface Example 
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Description 

 EDID Import 

On the EDID tab interface, click EDID Import. In the dialog box that appears, select an EDID 

file and click Open. 

 EDID Export 

On the EDID tab interface, click EDID Export. In the dialog box that appears, select a path 

and click Save. 

 

If you need to modify the content of an imported EDID file, just modify it and then re-import it to 

overwrite the original one. 
 

Configure Compatibility with Mac 

When the device is incompatible with the EDID of a Mac system, you may activate this feature 

to resolve the issue. 

Prerequisites 

None 

Notes 

None 

Interface Example 

 

Description 

Parameter Description 

Compatibility Turn on or turn off the function. 

 : On 
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Parameter Description 

 : Off 

Screen Configuration 

Configure Screen Topology 

Configure the cabinet topology to complete the physical wiring connections of the cabinets on 

the screen. 

Configure Online Cabinets 

Prerequisites 

The device is connected and cabinets are connected to the device. 

Operating Procedure 

Step  1 Select a device on the left side of the interface and then click Screen at the top of the page. 

Figure 5-8 Screen configuration (VX2000 Pro) 

 

Step  2 Select an Ethernet port at the bottom and then drag and click the mouse in the topology area 

to add cabinets. 



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 86 
 

The cabinets will be automatically connected when you are adding them, as shown in Figure 5-

9. The Ethernet port's loading capacity information will be displayed, as shown in Figure 5-10. 

Figure 5-9 Cabinets connected automatically 

 

Figure 5-10 Ethernet port capacity 

 

 2/3: Indicates that there are three cabinets connected to Ethernet port 1 and 2 of which are 

added to the topology. 

 12.66%: Indicates these two cabinets have used 12.66% of the Ethernet port capacity. 

 

 Swift Layout: If all the cabinets loaded by the Ethernet ports have the same model, resolution, 

and connection topology, you can use the Swift Layout function to quickly add and connect 

the cabinets for all the Ethernet ports. 

 Operating procedure: Click  and then drag the mouse in the topology area to add 

cabinets that match the actual requirements. In the properties area, select a layout and click 

Done. 
 

Step  3 Select other Ethernet ports and continue to add cabinets until all cabinets are connected. 

Step  4 For cabinets that have the same size and consecutive serial numbers, if you want to change the 

cabinet connection topology, select the cabinets and then select a quick topology under Quick 

topo in the properties area, as shown in Figure 5-11. For other cabinets, skip this step. 
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Figure 5-11 Quick topology 

 

Step  5 Do any of the following to arrange and align the cabinets and cabinet groups to let the cabinet 

positions meet the display requirements. 

 Use the function buttons. 

 

− Zoom to Selection: The selected element is zoomed and displayed in the center of the 

canvas. 

− Auto Fit: The canvas size is automatically adjusted to fit the topology area size. 

− Click  to show its drop-down menu shown below. The menu can be used to set the 

canvas grid. 

 

Grid: When toggled on ( ), a grid is displayed on the canvas. If you do not need to 

display the grid, set the switch to . 

Grid Color: Set the grid color. 
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Grid Spacing: Set the spacing of horizontal and vertical lines of the grid. The spacing is 

set to the resolution of the first cabinet by default. 

Snap to Cabinet: When positioning a cabinet near another one, the cabinet being 

moved will automatically align and snap to the edge of the adjacent cabinet, effectively 

eliminating gaps. 

Snap to Grid: The cabinet will be snapped to the grid. 

− Add Cabinet: Add online cabinets or cabinets in the cabinet library. 

 Use the right-click function menu 

− Select String: Select all the cabinets on the connection line of the current cabinet. 

− Change Model: Change the model of the current cabinet. 

− Select Same Cabinets: Select the cabinets of the same model of the current cabinet. 

− Blackout: Blackout the output image displayed on the current cabinet. 

− Freeze: Freeze the output image displayed on the current cabinet. 

− Swap: Swap the positions of the two selected cabinets. 

− Group: Select the desired cabinets and right click on them. Click Group in the context 

menu, and then the selected cabinets will be grouped for batch control. To set the 

group name and color, please select the group and set them in the properties area. You 

can also use the keyboard shortcuts Ctrl+G to perform the grouping operation. 

− Ungroup: Ungroup the cabinets. You can also use the keyboard shortcuts Ctrl+Shift+G 

to perform this action. 

− Add to: Add the selected cabinets to a group. 

− Clear Topology: Clear the current cabinet topology. 

− Delete: Delete the selected cabinet. You can also use the keyboard shortcuts Del to 

perform this action. 

 Right click on the canvas edge and use the function menu 
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− Zoom to Selection: The selected element is zoomed and displayed in the center of the 

canvas. 

− Fit Screen: The canvas size is automatically adjusted to fit the topology area size. 

− Zoom 1:1: The canvas size equals the input source resolution. 

− Display Grid: Display a grid on the canvas. 

− Snap to Grid: The cabinet will be snapped to the grid. 

− Snap to Cabinet: When positioning a cabinet near another one, the cabinet being 

moved will automatically align and snap to the edge of the adjacent cabinet, effectively 

eliminating gaps. 

− Display Topology: Display the cabinet connections. 

− Display Status: Display the cabinet status. 

Green: The cabinet is in the canvas area. 

Gray: The cabinet is offline. 

Orange: Some part of the cabinet is in the canvas area. 

Red: The entire cabinet is out of the canvas area. 

− Display Cabinet Color: Display a color icon at the top right corner of an Ethernet port. 

Once an Ethernet port is loading cabinets, a color icon will be displayed which is of the 

same color as the cabinet color. 

− Display Group Name: Display the cabinet group name. 

− Display Overlapping Cabinets: Display the overlapping cabinets. 



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 90 
 

Figure 5-12 Online cabinet topology (VX2000 Pro) 

 

 

 Use either Unico web page or NovaLCT to configure the screen. 

 Mapping is used to show the relations between the cabinets of the LED screen and the 

sending devices so that you can view or check the connections between the cabinets. 

 In the menu bar, go to File > Export Screen Config File to export the configured cabinet 

topology as a file (.scr). 

 In the menu bar, go to File > Import Screen Config File to import a saved screen configuration 

file for quick topology. 
 

Configure Screen Properties 

Set the screen-related properties in the property area on the right pane. 

Rename Screens 

Change the screen name. 

Prerequisites 

None 
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Notes 

None 

Interface Example 

 

Description 

On the Basic tab interface, enter a new screen name, and then click elsewhere in the interface 

to complete the screen name change. 

Configure Low Latency 

When the input source travels from where it comes to the processing device, sending device 

and then the receiving card, latency exists inevitably. Turning on this function can effectively 

help to reduce the latency from the input to output. 

Prerequisites 

None 

Notes 

To enable low latency, please make sure all Ethernet ports load the cabinets vertically and share 

the same Y coordinate. Free screen configuration (for example, Ethernet port 2 loads cabinets 

horizontally, or its Y coordinate is different from that of Ethernet port 1) will reduce the load 

capacity. 



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 92 
 

 

Interface Example 

 

Description 

Parameter Description 

Low Latency Turn on of turn off the function. 

 : On 

The device latency can be reduced by 1 frame. 

 : off 

Set Canvas Size 

Prerequisites 

None 

Notes 

None 
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Interface Example 

 

Description 

On the Basic tab interface, configure the following parameters. 

Parameter Description 

Resolution The size of the canvas, that is the size of the device effective loading area 

Config method: 

 Select the desired resolution from the drop-down list. 

 Select Custom from the drop-down list, and then set the width and height 

values. 

Generally, the size of the effective loading area should match with that of the 

physical screen. 

After you complete the settings, the system will automatically calculate the max 

output frame rate at the current resolution. 

Match Screen After the screen configuration is completed, click Match Screen and the system 

will automatically change the canvas size to the size of the circumscribed 

rectangles. 

Configure Test Patterns 

Test patterns are used to check the connection relation between the output connectors and the 

screen, and check whether the screen display is good. 

Prerequisites 

None 
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Notes 

None 

Interface Example 

 

Description 

On the Basic tab interface, configure the following parameters. 

Parameter Description 

Test Pattern Turn on or turn off the function. 

 : On 

 : Off 

After the function is enabled, select the desired test pattern. 

Brightness Set the brightness of the test pattern. 

Spacing Level Set the spacing between different color areas. 

If a multi-color test pattern is selected, this parameter is available. 

Spacing (px) Set the spacing between the lines. 

If a grid test pattern is selected, this parameter is available. 

Grid Width Set the width of the grid lines. 

Speed Set the moving speed of the lines. 
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Configure Output Color 

Configure the output color parameters. 

Prerequisites 

None 

Notes 

Note 

Interface Example 

 

Description 

On the Effect tab interface, configure the following parameters. 
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Parameter Description 

Contrast The ratio of the luminance of the brightest color to that of the darkest color 

Adjust the contrast value either as a whole or individually adjust the RGB 

components. 

Brightness The shading of lights in the image 

Adjust the brightness value either as a whole or individually adjust the RGB 

components. 

Hue The relative degree of how bright or dark the image is 

Saturation The color purity of the image 

The higher the value, the more vivid the color. 

Configure Cabinet Properties 

View Cabinet Info 

View cabinet-related info. 

Prerequisites 

None 

Notes 

None 

Interface Example 
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Description 

None 

Configure Cabinet Groups 

Change the cabinet group name and background color. 

Prerequisites 

A cabinet group has been created. 

Notes 

None 

Interface Example 

 

Description 

On the Cabinet Properties tab interface, configure the following parameters. 

Parameter Description 

Name The name of the cabinet group 

Config method: Enter a new group name, and then click elsewhere in the 

interface to complete the group name change. 

Color The background color of the group name 

Config method: Click the color block next to Group Color, and then select a 

standard color or enter RGB values to set the background color of the cabinet 

group name. 
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Configure Cabinet Positions 

Prerequisites 

None 

Notes 

The cabinet rotation in 90° increments feature is only supported by certain models of receiving 

cards, as detailed below: 

Model Description 

CA50E, XA50Pro, A10s Pro Supported by all versions. 

A8s-N, A7s Plus, A5s Plus Supported by V4.9.0.0 or later. 

Interface Example 

 

Description 

On the Cabinet Properties tab interface, configure the following parameters. 

Parameter Description 

Coordinates The position of the cabinet on the canvas 

 X: X coordinate of the cabinet on the canvas 

 Y: Y coordinate of the cabinet on the canvas 

Rotation (0°) Rotate the cabinet. Once the cabinet is rotated, the input source will display at 

the adjusted angle. 

Supported rotation angles: 0°, 90°, 180° and 270° 
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Set Cabinets 

Prerequisites 

None 

Notes 

None 

Interface Example 

 

Description 

On the Cabinet Properties tab interface, configure the following parameters. 

Parameter Description 

Blackout Turn on or turn off the function. 

 : On 

 : Off 

Freeze Turn on or turn off the function. 

 : On 

 : Off 

Indicator Turn on or turn off the function. 

 : On 

 : Off 

Light up Slowly Turn on or turn off the function. 

 : On 

 : Off 
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Parameter Description 

Once enabled, the display brightness will slowly change from 0 to the target value 

after the screen is powered on. 

Test Pattern Select a test pattern to perform screen aging test and troubleshoot problems. 

No Data Signal Set the display image after the Ethernet cable is disconnected. 

 Blackout: The screen displays a black image. 

 Previous Frame: The screen always displays the last frame. 

Configure Ethernet Port Backup 

Test whether the pre-stored images, backup Ethernet ports and devices take effect without 

plugging and unplugging the Ethernet cables. 

Prerequisites 

The pre-stored images, primary and backup Ethernet ports or primary and backup devices have 

been configured. 

Notes 

None 

Interface Example 

 

Description 

On the Cabinet Properties tab interface, configure the following parameters. 

Parameter Description 

Ports Redundancy Turn on or turn off the function. 

 : On 

 : Off 
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Parameter Description 

Backup Test Select the desired backup test. 

 Off: Enable the output of all the Ethernet ports on the current device to 

complete the test. 

 Backup Only: Disable the output of the primary Ethernet port on the current 

device to test whether the backup port or device takes effect. 

 Primary Only: Disable the output of the backup Ethernet port on the current 

device to test whether the output of the primary port is normal. 

 Disconnect All: Disable the output of all the Ethernet ports on the current 

device to test whether the pre-stored image takes effect. 

 

After enabling Ethernet port backup, a  icon is displayed between the primary and backup 

ports in the Ethernet port list. By default, the first half of the ports serve as backups for the 

second half. 
 

Screen Settings 

Adjust Image Quality 

Adjust the Gamma value and brightness of the output to enhance the overall image quality of 

the LED screen. 

Prerequisites 

None 

Notes 

None 
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Interface Example 

 

Description 

Select Screen Settings at the top of the page, and then on the Image Quality tab interface, 

configure the following parameters. 

Parameter Description 

Brightness The brightness of the LED screen 

Gamma Adjust the ratio of the screen brightness to the input level. The parameters are 

read from the receiving card, which default to optimal values at the factory. It is 

recommended the parameter adjustment be carried out by the trained personnel 

when necessary. 

Adjust Output 

Configure 3D 

Directly connect a third-party 3D emitter using the device's built-in 3D connector, or connect to 

the EMT200 emitter via the device's Ethernet port. Then, use the compatible 3D glasses to 

achieve a 3D display effect. 

Prerequisites 

 Video source format: Side-by side, top-and-bottom or frame sequential. 

 When paired with the EMT200, it is recommended to use a 3D source of 60Hz to enjoy an 

optimal experience. 

Notes 

 Enabling the 3D function will halve the device output capacity. 
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 The 3D function and input cropping cannot be enabled at the same time. 

 After enabling the 3D function on the Screen Settings page, 3D switches of all the layers will 

be toggled on. If you want to use a 2D layer, please toggle off the 3D switch of the desired 

layer in the property area of the Programming page. 

 The 3D effect follows the layer. The output area where a 3D layer is located always displays 

the 3D effect. 

Interface Example 

 

Description 

On the Output tab interface, configure the following parameters. 

Parameter Description 

3D Turn on or turn off the 3D function. 

 : On 

 : Off 

Source Format The format of the 3D video source 

Set the format to Side-by-Side, Top-and-Bottom or Frame Sequential according to 

the format of the accessed video source. 

Eye Priority Set which image is sent first, the right eye image or the left eye image. 

Put on the 3D glasses to view the screen. If the display appears abnormal, adjust the 

parameter value to the other one. If the display is normal, no further adjustments are 

needed. 

Third-Party 

Emitter 

Turn on or turn off the function. 

 : On 

 : Off 

Emitter Delay Set the delay time of sending the synchronization signal from the 3D signal emitter to 

the 3D glasses. This setting ensures that the switching between left and right eye 

images of the 3D glasses is in sync with the switching between the left and right eye 

images on the screen. This parameter is applicable to both the NovaStar and third-



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 104 
 

Parameter Description 

party emitters. 

Check Load 

Check the capacity usage of each Ethernet port of the device. 

Prerequisites 

None 

Notes 

None 

Interface Example 
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Description 

On the Output tab interface, click  next to the device information to check the usage of the 

device loading capacity. 

Layer Operations 

Add Layers 

Add layers to screen 

Prerequisites 

Make sure the device is in Video Controller mode before adding layers. 

Notes 

The maximum number of layers that can be added depends on the connected device. 

Device Model Number of Supported Layers (2K×1K) 

VX2000 Pro 12 

Operating Procedure 

Step  1 Select a device on the left side of the interface and then click Programming at the top of the 

page. 
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Figure 5-13 Programming (VX2000 Pro) 

 

Step  2 Add the layers to the screen. 

Drag an input source in the input list to the screen. 

Step  3 Perform the desired layer operations as required. 

Figure 5-14 Layer operations 
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Configure Video Source Properties 

In the input list, select an input source and set the relevant properties on the right pane. For 

detailed configurations and parameter descriptions, please refer to Configure Input Properties. 

Mosaic Source Settings 

Both HDMI and OPT sources support mosaicing. 

View Mosaic Source Info 

View the basic properties of the mosaic source and change the source name. 

Prerequisites 

A mosaic source has been configured and its signal is fine. 

Notes 

None 

Interface Example 
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Description 

On the Mosaic tab, type in a new source name and click anywhere else on the interface to save 

the change. 

Configure Mosaic Sources 

Set the mosaic source name, sub-source type, mosaic layout as well as sub-source size. 

Prerequisites 

None 

Notes 

Only the input sources of the same connector type support mosaicing, and the frame rates of 

sub-source must be the same. 

Interface Example 

 

Description 

On the Edit Mosaic tab interface, configure the following parameters. 

Parameter Name Description 

Name The name of the mosaic source 

Source Type The type of the sub-sources 

Config method: Select HDMI 1.3, HDMI 2.0 or OPT from the drop-down list. 

Layout The layout of the mosaic source 
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Parameter Name Description 

Config method: Select the desired layout from the standard layout template, and 

then drag the inputs in the input list to the sub-cells respectively. 

Sub-Source Size The size of the sub-sources 

 Default width: 1920 pixels, max width: 8192 pixels 

 Default height: 1080 pixels, max height: 8192 pixels 

 Max width and height: 4096×2160 

Configure USB Source Properties 

Select a USB source in the input list and configure relevant properties on the USB Playback 

Settings tab interface. 

The models of devices that support USB playback and the corresponding output resolutions for 

USB sources are listed below. 

Device Model USB Source Resolution 

VX2000 Pro 3840×2160@60Hz 

Play USB Files 

Prerequisites 

The U-DISK connector on the front panel is inserted with a USB drive which is successfully 

identified. 

Notes 

None 
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Interface Example 

 

Description 

In the playlist, select a file to play it and you can also stop the playback, play the previous or 

next file as well as set the playback mode. 

Configure Playback Parameters 

Prerequisites 

The U-DISK connector on the front panel is inserted with a USB drive which is successfully 

identified. 

Notes 

None 

Interface Example 
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Description 

On the Settings tab interface, configure the following parameters. 

Parameter Description 

Playback Mode The playback mode of the file 

 Repeat: Play the files in the playlist in order. Once the playback of 

the last file is completed, replay the first file. 

 Repeat in Order: Play the files in the playlist in order. Once the 

playback of the last file is completed, the screen will display a black 

image and the playback will stop. 

 Repeat One: Loop playback of the current file. 

File Type The type of the playback file 

 Video 

 Image 

 All: Video and Image 

 

After the file type is selected, only the file of the selected type will be 

displayed in the playlist. 

Playback Duration The duration of the image playback 

The value ranges from 1 to 60 and it defaults to 5. (Unit: s) 

Trans Effect The trans effect of the image 

Supported trans effect: Ripple, zoom in, push, flip, blinds, H wipe, V 

wipe, cube, dissolve, grid, swapping, scroll, fade in/out, twirl, heart 

trans, curtains, perspective triangle, disappear, bounce, star rotation 

Trans Duration The trans duration of the image 

The value ranges from 0.5 to 2 and it defaults to 0.5. (Unit: s) 

Auto Playback The auto playback switch 

Set whether to automatically play the USB files after the device is 

powered off and then power on with a USB drive inserted. 

 : On 

If Resume Playback not enabled, replay the files in the playlist in 

order; If enabled, replay the file being played before power failure 

from the beginning. 

 : Off 

Resume Playback Turn on or turn off the function. 
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Parameter Description 

 : On 

If a file is playing before the device power failure, enabling this 

function allows to replay the file from beginning after the device is 

powered on with a USB drive inserted. 

 Off: 

Replay the files in the playlist in order. 

 

 Enabling Resume Playback will also activate the Auto Playback 

feature at the same time. 

 After Resume Playback is enabled, if the file being played before 

power failure cannot be found, the files will be played from the 

beginning of the playlist in order. 

Configure Layer Properties 

Select the desired layer, and then set the layer-related properties in the property area on the 

right pane. 

Configure Basic Properties 

Configure the layer name, aspect ratio, position, size, as well as enabling the 3D effect. 

Prerequisites 

None 

 

Notes 

After enabling the 3D function on the Screen Settings page, 3D switches of all the layers will be 

toggled on. If you want to use a 2D layer, please toggle off the 3D switch of the desired layer in 

the property area of the Programming page. 
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Interface Example 

 

Description 

On the Basic tab interface, configure the following parameters. 

Parameter Description 

Name The layer name 

Aspect 

Ratio 

The ratio of the layer's width to its height 

After the aspect ratio is changed, the height of the layer remains unchanged, and the 

device automatically calculates its width. 

X The horizontal starting position of the layer on the screen 

The coordinates of the first pixel in the upper left corner of the screen are (0,0). 

Y The vertical starting position of the layer on the screen 

The coordinates of the first pixel in the upper left corner of the screen are (0,0). 

W The horizontal size of the layer 

The minimum width of a layer: 64 pixels 

H The vertical size of the layer 

The minimum height of a layer: 64 pixels 

3D Turn on or turn off the function 

 : On 

 : Off 
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Crop Layer Sources 

When there are black borders or other redundant info in the input source image, the required 

picture can be retained through the cropping the input source, so as to improve the screen 

utilization. 

Prerequisites 

A fine signal is connected to the input connector. 

Notes 

 The status and capacity of the cropped source remain consistent with the original one. 

 The input cropping and 3D functions cannot be enabled at the same time. 

Interface Example 

 

Description 

On the Advanced tab interface, configure the following parameters. 

Parameter Description 

Layer Source 

Crop 

Turn on or turn off the function. 

 : On 

 : Off 

X The horizontal start position of the cropped area relative to the original source 

Y The vertical start position of the cropped area relative to the original source 
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Parameter Description 

Width The number of horizontal pixels (width) of the cropped area 

Height The number of vertical pixels (height) of the cropped area 

Manage Presets 

To manage the presets, click Preset on the right side of the Programming interface and perform 

the corresponding actions as needed. 

 

Save Presets 

 

Step  1 On the Preset tab interface, click Save Preset at the bottom, and then a pop-up window will 

appear showing the preset numbers. 

Figure 5-15 Bind presets (VX2000 Pro) 

 

Step  2 In the Bind Key window, select the desired key number to save the current layer information to 

the preset. 

One key number corresponds to one preset. The name of the save preset: Preset X ("X" refers to 

the bound key number.) 
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Load Presets 

In the preset list, select the desired preset to load it. 

After the preset is successfully loaded, the corresponding indicator light at the top left of the 

preview area will light up: 

 : The preset is not loaded. 

 : The preset is loaded. 

Rename Presets 

Place the mouse over the preset and click . Enter a new name and then click elsewhere to 

make the change take effect. 

Delete Single Presets 

Place the mouse over the preset and click . In the pop-up dialog box, click Yes. 

Delete All Presets 

Click Edit, check Select All, and click . In the pop-up dialog box, click Yes. 

Maintenance 

Device Maintenance 

In the menu bar, select Maintain. Select the Device tab and the target devices, and then do the 

following as required. 
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Figure 5-16 Device maintenance (VX2000 Pro) 

 

Restart 

Click Restart. In the displayed dialog box, click Yes to restart the device. 

Factory Reset 

 

 Please do this with great caution. 

 The reset action does not affect the device firmware version. 

 Power-off is NOT allowed during the reset process. 

 The device will restart automatically after the reset is completed. 
 

Click Factory Reset. In the pop-up dialog box, select Keep user data or Reset all, and then 

click OK. 

 Keep user data 

Retain the device IP address, input connector EDID, gallery files, device language settings, 

device name and belonged project. 

 Reset all 

Retain the device IP address and belonged project. 
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Figure 5-17 Factory reset 

 

Export Logs 

Click Export Log. In the dialog box that appears, select a path and click Save to save the device 

logs to local computer. 

Device Diagnostics 

In the menu bar, select Maintain. Select the Diagnostics tab, select a device from the drop-

down list, and click Diagnostics. 

After the diagnostics completes, you can view the test result and take necessary measures as 

required. 

Figure 5-18 Device diagnostics (VX2000 Pro) 
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Other Settings 

Switch UI Language 

In the menu bar, go to Settings > Language to switch the UI language. 

Export Logs 

In the menu bar, go to Settings > Export Log to export the logs. 

Configure Device Backup 

Device backup allows you to set the backup relationship between two devices. You can set one 

of the devices as the primary device or the backup device. When the primary device has a 

problem or the primary device's Ethernet cable fails, the backup device will take over the 

responsibilities of the primary device seamlessly and continue to work well to ensure the LED 

screen will not go black. 

Prerequisites 

 Before creating a backup relation, make sure that both the primary and backup devices are 

on the same LAN. 

 In a backup relation, the models and device versions of the primary and backup devices must 

be the same. 

Notes 

 You have three options to create a backup relation: NovaLCT, Unico web page, or the device 

LCD menu. However, be aware that these methods do not synchronize with each other. 

Using more than one can lead to data problems. To prevent issues, choose only one method 

for setting up your backup. If you do mix them, you'll need to reset the device to factory 

settings and start over with just one method. 

 In the device backup mode, the quantity of the cabinets loaded by each Ethernet port on 

both the primary and backup devices must be the same, but their data flow must be in a 

reversed way. 
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Operation Procedure 

Step  1 In the menu bar, go to Settings > Device Backup. 

Step  2 In the pop-up window, click Add to add a backup relation. 

Figure 5-19 Add backup relations 

 

Step  3 Select the primary and backup devices from the drop-down lists respectively. 

After the action completes, the firmware versions of the primary and backup devices will be 

displayed. 

Step  4 Click OK to complete the backup relation settings. 

Step  5 (Optional) Click Delete to delete the desired backup relation. 

Manage Cabinet Library 

In the menu bar, go to Settings > Cabinet Library. Do the followings as needed to manage the 

cabinet library files. 



 
VX Pro Series All-in-One Controller User Manual 

 

 

www.novastar.tech 121 
 

 

Upload Cabinet Files 

Step  1 Click Add and select the cabinet type in the displayed window. 

Figure 5-20 Cabinet file 

 

Step  2 Select the .rcgx file to be imported from the local computer and click Upload. 

After the file is selected, you can click Delete to delete the uploaded file. 

Export Cabinet Files 

Step  1 Select one or more files on the Cabinet Library interface and then click Export. 

For batch export, multiple files will be compressed as a .zip file and exported. 

Step  2 Select a local directory and click Save. 
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Sync Cabinet Files 

 Sync cabinet files between devices 

1) Select the files to be synced (multiple files can be selected), and click Sync Cabinet 

Library. 

2) On the displayed window, select the devices to which the files are synced (multiple 

devices can be selected). 

 

3) Click OK. 

View Cabinet and Flash Info 

Select a cabinet file, and the information about all the cabinets that use this cabinet file will be 

displayed. 

Configure Preferences 

In the menu bar, navigate to Settings > Preferences. Turn on the desired features (checked "√") 

or off (unchecked). 

 Screen Resources: Show the layer resources on the Programming interface if enabled. 

Help 

In the menu bar, go to Help > About Us to view the related info. 
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