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1 Software Introduction 

VMP, short for Vision Management Platform, is an application in the brand-new control system COEX series. 
Featuring innovative interaction design and plenty of practical functions, such as project management, screen 
configuration, input settings, display correction, color processing, screen settings, system backup, monitoring and 
maintenance, screen brightness schedule, and preset management, it provides users with an efficient and easy 
operation and control experience. 

 Easy and convenient management at screen level 

Devices of the same model and version can be added to the same screen for management, allowing for batch 
operations and greatly increasing work efficiency. 

 Fast and flexible configuration 

The cabinets can be quickly connected, flexibly arranged and aligned, significantly simplifying screen 
configuration. 

 Distinct topology area and properties areas 

The screen topology is clear at a glance, the input source can be previewed in real time in the topology area 
and various properties can be easily set. 
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2 UI Introduction 

Figure 2-1 UI Introduction 

 

Note: 

 All the figures in this document use operations in Windows10 as examples. 

 You can refer to section 7.3 Lock and Unlock Correction Page to lock the Correction page to avoid changing 

the display content due to misoperation. 
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3 Install VMP 

3.1 Windows 

Prerequisites 

 The VMP software package is prepared. 

 A computer meeting the following requirements is available. 

− OS: Windows 10 (64-bit) or later 

− CPU: i5 or later 

− RAM: 8 GB or greater 

Note 

ARM-based Windows computers are not supported. 

Installation Method 

Run the Coex VMP Setup.exe file and follow the setup wizard to complete the installation. If a firewall prompt 

appears, choose to allow the installation. 

Installation Result 

If the installation is successful, the VMP software shortcut  appears on the desktop. 

3.2 MacOS 

Prerequisites 

 The VMP software package is prepared. 

 A computer meeting the following requirements is available. 

− OS: MacOS 10.15 or later 

− CPU: Intel i5 or Apple M1 or later 

− RAM: 8 GB or greater 

Installation Method 

Step 1 After the installation package is downloaded, click Finder on the desktop, enter the Downloads page, and double-

click the package to open VMP.dmg.  

Step 2 Hold down the control key, click  and select Open. 
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4 Device Management 

4.1 Connect Online Device 

Via Ethernet Cable 

Connect the controller and the control PC directly via Ethernet cable and set a static IP address for the controller to 
let the controller and control PC be on the same network segment. The MX40 Pro LED display controller is used as 
an example in this section. 

Step 1 Follow Figure 4-1 to complete the hardware connection. 

Figure 4-1 Connecting devices via Ethernet cable 

 

Step 2 Press the knob of the controller to enter the menu and choose Communication Settings > Network Settings. 

Step 3 Set Mode to Manual. 

Step 4 Set IP Address, Subnet Mask and Default Gateway and ensure the controller and control PC are on the same 

network segment. 

To reset the network settings to the default values, please select Default and press the knob. 

Step 5 After the settings, select Apply and press the knob. 

Via LAN 

Connect the controller and the control PC to the same LAN via a router and set the controller to automatically obtain 
an IP address. The MX40 Pro LED display controller is used as an example in this section. 

Step 1 Follow Figure 4-2 to complete the hardware connection. 

Figure 4-2 Connecting devices via LAN 

 

Step 2 Press the knob of the controller to enter the menu and choose Communication Settings > Network Settings. 

Step 3 Set Mode to Auto. 

Step 4 Select Apply and press the knob. 
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Related Information 

 The online devices that are connected will be categorized according to the projects, screen groups, and 

individual screens of each device. Any new devices will be shown in the default project. 

 For card-based devices like the MX6000 Pro and MX2000 Pro, you can install different models of output cards 

for the same device. However, output cards of different models do not support loading the same screen. 

4.2 Add Offline Device 

Before the LED screen is constructed on-site, you can add offline devices and pre-configure the screen settings. You 
can then easily import the pre-configured project settings for swift and hassle-free usage of the LED screen. 

Operating Procedure 

Step 1 From the menu bar, choose Tools > Offline Mode > Enter Offline Mode. 

Step 2 Click  at the top left and then select Add Device to add offline devices. 

Step 3 Add one or multiple devices as needed. Up to 25 offline devices can be added. 

Step 4 Click Add Controller in the pop- up window. 

To add multiple devices of the same model, click Batch Add. 

Figure 4-3 Add controller 

 

Step 5 Enter the device type, device name, and IP address. 

For card-based devices like the MX6000 Pro and MX2000 Pro, click  to enter the input/output card model. You 
can install different models of output cards for the same device. However, output cards of different models do not 
support loading the same screen. 

Click  to copy the current controller and click  to delete it. 

Step 6 Click OK once you are done. 

Related Information 

 The added offline devices will be displayed at the bottom of the selected project/screen. 

 When no target is selected, added offline devices will be displayed at the bottom of the Default Project. 

 To exit offline mode, choose Tools > Offline Mode > Exit Offline Mode, or close VMP and reopen it. 

4.3 Manage Project List 

The project list is categorized into four levels: project, screen group, screen, and controller. Screen groups, screens, 
and controllers can be added to the project for centralized management and batch operations. 

This chapter will introduce the operations related to the project list by using the example of creating a new project and 
screen, as well as managing the connected controllers. 
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Operating Procedure 

Step 1 Click  at the top left and then select New Project to create a project. 

To delete a project, right-click the project and then select Close from the pop-up menu. 

Figure 4-4 Project list 

  

Step 2 To create a screen for a project, first select the project and then click  at the top left and then select New 

Project. 

 When you have multiple screens in the project, you can drag a screen to overlap with another one and create a 

screen group. 

You can perform screen control (blackout/freeze), image quality adjustment, and thermal compensation settings 
on the selected screen group. 

 

 You can drag and drop a screen group or screen to another project. 

Step 3 You can also drag and drop a controller to another screen. 

 Controllers and output cards of different models or firmware versions cannot be added to the same screen. 

 Dragging a controller to a new screen will apply all the sending card parameters of that screen. 

 Click the  icon at the top right of the list to hide controllers and only show projects, screen groups, and 

screens. 
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Related Operations 

 Rename: 

Right-click a project/screen group/screen/controller and then select Rename from the pop-up menu. 

 Screen Control: 

Right-click a project/screen group/screen/controller and then select Blackout or Freeze from the pop-up menu. 

 Enable Mapping: 

Right-click on a screen/controller and select Mapping, Controller Finder, and Canvas Mapping for a clear 

view of the positions and connection topology of the receiving cards, as well as the controller and canvas 
positions. 

 Controller Properties 

Right-click a controller and then select Controller Properties to open the corresponding interface. 

  

− Check the basic information 

Check the controller model, SN, firmware version, IP address, MAC address, etc. 

− Check the detailed information 

Click  to expand the panel and check the detailed controller hardware and software information. 

− Check input/output card information 

Check the input/output card name, model, SN, firmware version, hardware version and other information 
when connecting to card-based controllers (MX6000 Pro and MX2000 Pro). 

− Sync time 

Toggle on the Set time automatically ( ). If the device is connected to VMP, it will automatically sync the 

time from the control computer to the device. 

− Modify time 

When Set time automatically is toggled off ( ), click the Controller time widget and then modify the 

time. 

− Export logs 

Click Export Log, select a save path, set the file name, and click Save. 

4.4 Export and Import Project 

Export the project files (.nprj) so that you can import the files to apply the configuration data to the same kind of 
devices, improving the configuration efficiency. 
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Prerequisites 

The project file can be imported to a device that is of the same model. For card-cased controllers (MX6000 Pro and 
MX2000 Pro), you also need to make sure the card slot and model in the file match the device. 

 If the project file version is higher than that of the device, you will be prompted to upgrade the device firmware 

during the import. Please note that the features of the new version will not be supported by the device. 

 If the project file version is lower than that of the device, you can import it without any issues. 

Export Project Files 

Step 1 From the menu bar, choose Project > Export and select a project. 

You can also right-click a project and select Export from the pop-up menu. 

Step 2 Select a local directory and click Save. 

Step 3 After successful export, click OK to close the prompt box. 

Figure 4-5 Successful export 

 

Import Project Files 

Step 1 From the menu bar, choose Project > Import and select a project. 

You can also right-click a project and select Import from the pop-up menu. 

Step 2 Select a local project file and click Open. 

After successful device matching, a dialog box as shown in Figure 4-6 is displayed. 

Figure 4-6 Matching devices 

 

Step 3 Click Confirm. 

Step 4 After successful import, click OK to close the prompt box. 
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Figure 4-7 Successful import 

 

4.5 Manage Peripherals 

VMP supports detecting all multifunction cards and light sensors connected to the project controllers, as well as 
enabling power control through the multifunction cards. 

Applicable Products 

 Multifunction card: MFN30 

 Light sensor: NS060 

Operating Procedure 

Step 1 Select a project from the project list. 

 

Step 2 In the Peripheral section below the project list, you can check the multifunction cards connected to all the controllers 

with the project, as well as the light sensors connected to the multifunction cards. 

Step 3 Select a peripheral to view its information in the properties area on the right. 

 Multifunction card: You can view the model, position, and firmware version. 

 Light sensor: You can view the position and ambient brightness. 

Note 

When using the multifunction card (MFN300-B V4.4.2.0 or later), make sure to connect it to the controller's first 16 

ports. For other versions of the multifunction card, it is advisable to connect it to port 1 of the controller. 

Step 4 Perform power control operations as needed. 
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Select a multifunction card and set the power control mode in the properties area on the right. You can choose 
between the auto and manual mode. You can also click Power on or Power off to control the state of all power 

channels. 

 Manual mode: Set the state of each individual power channel. 

 Auto mode: Different start and shutdown times can be set for each power channel, with default times retrieved 

from the multifunction card. 

4.6 Art-Net Control 

Enabler the Art-Net protocol switch to realize control via third-party device. 

Applicable Products 

MX40 Pro, MX30, MX20, KU20 

Prerequisites 

To apply the Art-Net protocol, make sure the transmitter ends (such as console and control PC) and the receiver ends 
(such as LED display control system and lighting system) are on the same LAN. 

Related Information 

After the Art-Net protocol switch is enabled, the configured parameters cannot be modified. For the protocol details, 
see Art-Net Protocol Instructions. 

Operating Procedure 

From the menu bar, choose Tools > Control, enable the Art-Net switch, and complete the Source, Image Quality 
and Preset parameter configurations. 

Figure 4-8 Art-Net switch 
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5 Screen Configuration 

5.1 Edit Screens 

Edit the settings of the selected screen. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Operating Procedure 

Step 1 Select a screen from the project list and then select Layout. 

Figure 5-1 Layout 

 

Step 2 Click Edit in the properties area on the right. 

Step 3 Enter a screen name on the pop-up window. 

Figure 5-2 Edit screen 

 

Step 4 Select a Working Mode. When operating as a Send-Only Controller, the display latency is reduced by 1 frame. 
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Step 5 Set Low Latency. 

When low latency is set to , the latency at the data sending end is reduced by 1 frame. 

Step 6 When a card-based controller (MX6000 Pro or MX2000 Pro) operates as a Send-Only Controller, you also need to 

do the following. 

1. Choose a layer alignment from the four options. 

For , , or , you can adjust the layer size by dragging the layer divider, or setting a value under 
the Canvas Size section. 

 

2. Set the state of Pixel to Pixel. 

When Pixel to Pixel is enabled ( ), it will output the display based on the size of the input source in a pixel-

to-pixel manner. 

When Pixel to Pixel is disabled ( ), the input source will automatically scale to fill the layer based on the 

configured layer size. 

Step 7 Click OK once you are done. 

Note 

Pay attention to the following when using the low latency function. 

 Low latency, frame multiplication, and 3D cannot be enabled at the same time. 

 When low latency is enabled, the sync source cannot be set to Genlock. 

 To enable low latency, please make sure all Ethernet ports load the cabinets vertically and share the same Y 

coordinate. Free screen configuration (for example, Ethernet port 2 loads cabinets horizontally, or its Y 

coordinate is different from that of Ethernet port 1) will reduce the load capacity. 

 

5.2 Set Canvas Size 

Step 1 Select a screen, controller, or output card from the project list and then select Layout. 

Step 2 In Canvas Size section, select a pre-defined resolution from the drop-down list or customize the width and height of 

the canvas. The maximum supported setting is 16384. 

The system will automatically calculate the maximum frame rate for the canvas based on the current resolution. 
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Figure 5-3 Canvas size 

 

Step 3 When a card-based controller (MX6000 Pro or MX2000 Pro) operates as a Send-Only Controller, you can set the 

layer divider. 

For , , or , you can adjust the layer size by dragging the layer divider, or setting a value for the divider. 

 

5.3 Configure Screen Topology 

Configure the cabinet topological diagram to complete the logical connection of the cabinets. 

Prerequisites 

The controller is connected and cabinets are connected to the controller. 

Operating Procedure 

Step 1 Select a controller from the project list and then select Layout. 

Figure 5-4 Layout 
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Step 2 Choose View > Display from the menu bar, select a view for the topology area, and choose what to display on the 

topology. 

Select a view or switch pages by clicking one of the icons in the top right corner of the topology area: 

 : Show the cabinets only. 

 : Show the preview image of the input source only. 

 : Show the cabinets and preview image of the input source at the same time. 

 : Click to enable Source Snapshot. When this is enabled, the source playback in VMP will freeze on the 

last frame and the display on the LED screen will not be affected. Users can then adjust screen settings based 

on the frozen image without needing to look at the LED screen. To disable Source Snapshot, simply click the 

icon again. 

 : Click to switch pages in the dropdown menu. VMP supports a fixed total of 8 pages. When 

multiple screens are displaying the same content, you can configure screen layout at different pages and choose 

to show or hide them as needed. Click  to clear all topologies. 

 

You can choose the content to be displayed in the topology area, including cabinet topology, cabinet status, group 
names, source tags, and overlapping cabinets. 

Step 3 Select an Ethernet port at the bottom and then drag or click the mouse in the topology area to add cabinets. 

The cabinets will be automatically connected when you are adding them, as shown in Figure 5-5. The Ethernet port’s 

load capacity information will be displayed, as shown in Figure 5-6. The properties area will display the cabinet 
specifications, as shown in Figure 5-7. You can also select a custom cabinet and click Edit to modify the 

specifications of the cabinet. 

Figure 5-5 Cabinets connected automatically 

 

Figure 5-6 Ethernet port capacity 

 

 2/32: Indicates that there are 32 cabinets connected to Ethernet ports 1 and 2 which are added to the topology. 

 12%: Indicates these 2 cabinets have used 12% of the Ethernet port's capacity. 
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Figure 5-7 Edit cabinet specifications (only available in offline mode) 

 

Note 

 Swift Layout: If all the cabinets loaded by the Ethernet ports have the same model, resolution, and connection 

topology, you can use the Swift Layout function to quickly add and connect the cabinets for all the Ethernet 

ports. 

 Operating procedure: Click  and then drag the mouse on the canvas to add cabinets that match 

the actual requirements. In the properties area, select a layout and click Done. 

Step 4 Select other Ethernet ports and continue to add cabinets until all cabinets are connected. 

Step 5 For cabinets that have the same size and consecutive serial numbers, if you want to change the cabinet connection 

topology, select the cabinets and then select a quick topology under Quick topo in the properties area, as shown in 

Figure 5-8. For other cabinets, skip this step. 

Figure 5-8 Quick topology 

 

Step 6 Do any of the following to arrange and align the cabinets and cabinet groups to let the cabinet positions meet the 

display requirements. 

 Use the function buttons 

 

− 1:1: The canvas size equals the input source resolution. 

− Zoom to Selection: The selected element is zoomed and displayed in the center of the canvas. 

− Fit Screen: The canvas size is automatically adjusted to fit the topology area size. 
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Click  to show its drop-down menu shown below. The menu can be used to set the canvas grid. 

 

− Grid: When toggled on ( ), a grid is displayed on the canvas. If you do not need to display the grid, set the 

switch to . 

− Color: Set the grid color. 

− Spacing: Set the spacing of horizontal and vertical lines of the grid. The spacing is set to the resolution of the 

first cabinet by default. 

− Snap to Cabinet: When positioning a cabinet near another one, the cabinet being moved will automatically 

align and snap to the edge of the adjacent cabinet, effectively eliminating gaps. 

− Snap to Grid: The cabinet will be snapped to the grid. 

 Use the function menus on the menu bar 

− Edit menu 

 

− View menu 

 

 Use the right-click function menus 

− Right click the canvas 

 

Zoom to Controller: The selected controller is zoomed and displayed in the middle of the topology area. 

− Right click the cabinet 
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Select String: Select all the cabinets on the connection line of the current cabinet. 

Swap: Swap the positions of the two selected cabinets. 

Group: Group the selected cabinets. To set the group name and color, please select the group and set them 
in the properties area. 

Ungroup: Ungroup the cabinets. 

Add to: Add the selected cabinets to a group. 

Move to: Move the selected cabinets to the specified page. 

 Set cabinet coordinates and rotation 

Select a cabinet and specify its coordinates and rotation angle in the properties area. Once the cabinet is 
rotated, the input source will display at the adjusted angle. 

The cabinet rotation in 90° increments feature is only supported by certain models of receiving cards, as 

detailed below: 

Table 5-1 Receiving cards supporting cabinet rotation 

Model Description 

CA50E, XA50Pro, A10s Pro Supported by all versions. 

A8s-N, A7s Plus, A5s Plus Supported by V4.9.0.0 or later. 

5.4 Set the Cabinet 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Operating Procedure 

Select a cabinet, canvas, or screen and then select Layout. Do any of the following operations in the properties area. 

Figure 5-9 Cabinet settings 

 

 Control Display Status 

Set the Blackout or Freeze switch to . 

 Enable Indicator 
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If the cabinet has a running status indicator, you can set the Indicator switch to . 

 Enable the Light Up Slowly Function 

Set the Light up slowly switch to  so that after the screen is powered on, the display brightness will slowly 

change from 0 to the target value. 

 Set Test Pattern 

Select a test pattern from the drop-down list of Test Pattern to perform screen aging test and troubleshoot 

problems. 

 Set Image for Abnormal Situations 

Select an option from the No data signal drop-down list. 

− Blackout: The screen displays a black image. 

− Last Frame: The screen always displays the last frame. 

5.5 Set OPT Ports 

Applicable Products 

MX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Layout. 

Step 2 Set the output mode of the OPT ports under OPT Settings. You can choose either 20 Ports Mode or 40 Ports Mode. 

 20 Ports Mode 

− OPT 1 transmits the data of Ethernet ports 1 to 10. OPT 3 is the copy channel of OPT 1. 

− OPT 2 transmits the data of Ethernet ports 11 to 20. OPT 4 is the copy channel of OPT 2. 

− You can use the optical port alongside the physical Ethernet port, with priority given in the following order: 

OPT 1/2 > OPT 3/4 > Ethernet ports 1–20. 

 40 Ports Mode 

− OPT 1 copies and outputs the data of Ethernet ports 1–10. 

− OPT 2 copies and outputs the data of Ethernet ports 11–20. 

− OPT 3 copies and outputs the data of Ethernet ports 21–30. 

− OPT 4 copies and outputs the data of Ethernet ports 31–40. 

− You can use the optical port alongside the physical Ethernet port, with priority given in the following order: 

OPT 1/2 > Ethernet ports 1–20. 

Figure 5-10 OPT settings 
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Note 

 When both the optical and Ethernet ports are used simultaneously, please do NOT connect the device's 

Ethernet port with the same number as the one of the optical port to the receiving card at the same time. If they 

are connected simultaneously, the display effect of the optical port will take precedence. 

 When Ethernet port backup is enabled in 40-port mode, the last 20 Ethernet ports are backed up by the first 20 

Ethernet ports. When switching to the 20-port mode, please remember to remove the loop backup setup of the 

receiving card. 

 While in the 40-port mode, additional Ethernet ports can be used to create easier screen topology without 

reducing the device's maximum load capacity. 
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6 Input Source Configuration 

6.1 Set Layers 

Add layers and set the layer properties. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Prerequisites 

 For single-card controllers (MX40 Pro, MX30, MX20, KU20), the Layers function is only available while under All-

In-One Controller mode. Please refer to 5.1 Edit Screens for more details. 

 For card-based controllers (MX6000 Pro and MX2000 Pro), the Layers function is available for both All-In-One 

Controller and Send-Only Controller modes. 

− All-In-One Controller supports free layer layout; 

− Send-Only Controller follows a fixed layer layout with a predetermined layer quantity. 

Related Information 

The maximum number of layers that can be added depends on the connected device. When the supported layer 
quantity is 1, layer position, border, input crop and other operations are not supported. 

Device Model Number of Supported Layers 

MX40 Pro 4 

MX30 3 

MX20 3 

KU20 1 

MX6000 Pro 32 (Each input card supports 4 layers, and up to 8 input cards can be used at the same time.) 

MX2000 Pro 8 (Each input card supports 4 layers, and up to 2 input cards can be used at the same time.) 

Operating Procedure 

Step 1 Select a controller or screen from the project list and then select Source. 
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Figure 6-1 Input source 

 

Step 2 Select an input card at the bottom of the page when there are multiple input cards. 

Step 3 Double-click the thumbnail of the input source or drag the input source to the target position to add a layer. 

You can check the source status according to the source indicator: 

 Green: The input source is connected. 

 Red: The input source is being used for the screen but is not connected. 

 Gray: The input source is not connected. 

Step 4 Make layer adjustments as needed. 

 Lock layer 

 

 Switch source 

− Select a layer and select another source in the properties area. 

 

− Right-click a layer, select Source from the pop-up menu, and select another source. 

 Adjust layer size and position 

− Select a layer and set the layer size and coordinates in the properties area. You can also bring the layer to 

front or send it to back. 

 

− Right-click a layer and select Bring to Front, Send to Back, Bring Forward or Send Backward from the 

pop-up menu. 
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− At the top right of a layer, click a function icon to set the layer. 

: Lock the layer. 

: Unlock the layer. 

: The layer size is the same as the input source resolution. 

: The layer automatically fills the screen. 

: The layer size changes automatically according to the canvas size. 

: Delete the layer. 

 Set borders 

Select a layer and enable or disable the layer borders function in the properties area. After enabling the function, 
you can set the border thickness and color. 

 

 Crop the input source 

Select a layer and enable or disable the Crop function in the properties area. Then, you can set the crop size 

and position on the thumbnail of the layer. You can also make adjustments by setting the parameter values 

below the thumbnail. When Same as Layer Size is set to , the input source image will be cropped 

according to the layer size. 
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6.2 Set External Sources 

Select a controller from the project list and then select Source. Select an external source from the source list and do 

the following as required. 

6.2.1 Set Max Bandwidth for Input Source 

When installing an 8K input card in a card-based controller, it is necessary to configure the maximum bandwidth for 
the input source in order to calculate the layer resources of the input ports. 

Applicable Products 

MX6000 Pro, MX2000 Pro 

Operating Procedure 

Select an option from the drop-down list to calculate the layer resources. Figure 6-2 takes the MX_2xDP1.4 input 
card as an example.  

 4096*2160@60Hz: Up to 4 layers can be added. 

 8192*2160@60Hz: The maximum number of layers that can be added is determined based on the size of the 

input source used in the currently enabled layers of the input card. For example: 

- When using two input sources of 8192×2160@60Hz, a maximum of two layers can be added. 

- When using one input source of 8192×2160@60Hz and two input sources of 4096×2160@60Hz, a 

maximum of three layers can be added. 

Figure 6-2 Maximum bandwidth 

 

6.2.2 Set ST 2110 Parameters 

When installing ST 2110 input cards in card-based controllers like the MX6000 Pro and MX2000 Pro, you need to 
configure the video stream for the input source, set the IP addresses for the primary and backup OPT ports, and 
establish the PTP configuration. 

Applicable Products 

MX6000 Pro, MX2000 Pro 

Operating Procedure 

Step 1 Select the ST 2110 input card from the source list and navigate to the ST 2110 Settings in the properties area on the 

right. 
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Figure 6-3 ST 2110 settings 

 

Step 2 Under the Video Stream section, you can set the ST 2110 port information using either of the following two methods. 

 Method 1: Click  to load the SDP file for configuration. 

 Method 2: Fill in the below parameters to complete the OPT configuration. 

− Destination IP (primary/backup OPT ports) 

− Port (primary/backup OPT ports) 

− Source IP (primary/backup OPT ports) 

Step 3 Under the Video Stream section, you can set the ST 2110 source information. 

Select an option from the drop-down lists of Resolution, Refresh Rate, Color Space/Sampling, and Bit Depth and 
then click Apply. You can also set a custom resolution. 

Step 4 Set the primary and backup OPT IP addresses for the ST 2110 input card under the Primary OPT IP and Backup 

OPT IP sections. 

You can enter the IP address manually or simply toggle on Obtain Automatically. Remember to click Apply once 

you are done. 

Note: 

Please assign different subnet IP addresses to the optical ports on the ST 2110 card. Failure to do so may result in 

NMOS malfunctions due to network card routing issues. 

Example: (SFP1: 192.168.0.20, SFP2: 192.168.1.20). 

Step 5 Enable or disable Input is Locked to PTP under the PTP Settings. 

When this is enabled, it can synchronize with the master clock on the network. Remember to click Apply once you 

are done. 
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Figure 6-4 PTP 

 

Note 

If the Time Lock Status in the PTP Status section shows Unlocked, enabling Input is Locked to PTP may result in 

display abnormalities. 

Step 6 You can view the Master Clock MAC, Time Lock Status, and Offset from Leader under PTP Status. 

6.2.3 Set Resolution and Refresh Rate 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Related Information 

If the resolutions of the input source and screen are the same, the image can be displayed pixel to pixel. 

A lower frame rate may result in image flickering, while a higher refresh rate helps stabilize the display image. 

Operating Procedure 

Select a value from the drop-down lists of Resolution and Refresh Rate and click Apply. 

Figure 6-5 EDID 

 

6.2.4 Adjust the Color 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Operating Procedure 

Step 1 In the InfoFrame Override area, select a value from the drop-down lists of Color Space/Sampling, Gamut and 

Quantization Range. 

The override parameter will be used in the calculation of color adjustment. Select From Input and the software will 

read the attribute value that comes with the input source. 
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Figure 6-6 InfoFrame Override 

 

Step 2 In the Color area, drag the sliders to adjust the parameter values. 

Figure 6-7 Color 

 

Table 6-1 Descriptions of color adjustment parameters 

Parameter Description 

Black Level It is used to adjust the brightness of the dark areas of the image. The smaller the 
value, the darker the dark part of the screen. 

Contrast It is used to adjust the brightness of the highlighted areas of the image. The greater 
the value, the brighter the highlight part of the screen. 

Contrast and black level together affect the overall contrast of the image. 

Saturation It is used to adjust the color purity of the image. The greater the value, the more 
vivid the color. 

Hue It is used to adjust the color effect of the displayed image color. Generally, it is 
divided into warm, cool and intermediate tones. 

Red Shadow/Green 
Shadow/Blue Shadow 

It is used to adjust the brightness of the dark areas of the image. The principle is the 
same as that of black level, but only the RGB components are adjusted. 

Red Highlight/Green 
Highlight/Blue Highlight 

It is used to adjust the brightness of the highlighted areas of the image. The 
principle is the same as that of contrast, but only the RGB components are adjusted. 

6.2.5 Set HDR Parameters 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30 

Related Information 

Supports automatic parsing and manual setting of HDR. For 12G-SDI, DP1.2, and non-standard HDR sources, they 
can only be set to HDR properties manually. 
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Using the HDR function together with the A10s Pro and CA50E receiving cards will not reduce the Ethernet port load 
capacity by half. For details, see the COEX series LED display controller specifications. 

Operating Procedure 

Select an HDR format from the drop-down list of Format and set related parameters. Select Auto and the software 

will read the attribute value that comes with the input source. 

Figure 6-8 HDR 

 

HDR10 parameters: 

 PQ Mode: The mapping method of video source brightness. 

− ST2084 (PQ): This mode 1:1 maps the brightness of the video source. The part that exceeds the maximum 

screen brightness will still be displayed as the maximum screen brightness. 

− ST2086 (Linear mapping): This mode linearly maps the brightness of the video source. It globally adjusts the 

video source brightness according to the maximum screen brightness to ensure that the ratio of the 

brightness of the entire source content remains unchanged. 

 MaxCLL: The override value of the maximum video source brightness. MaxCLL takes effect when Override is 

selected. 

Note 

HDR 2084 and brightness scheme cannot be enabled at the same time. If HDR 2084 is selected while the brightness 

scheme is already enabled, the brightness scheme will take precedence. 

6.3 Set Internal Sources 

Select the internal source and set the related parameters for screen testing and troubleshooting. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Operating Procedure 

Step 1 Select a controller from the project list and then select Source. 

Step 2 Double-click the thumbnail of internal source in the source list at the bottom of the page, or select Internal Source 

from the drop-down list next to Select Source in the properties area on the right. 

Step 3 Select an image and set the Grayscale, Gradient Stretch, Speed, and Space. The adjustable parameters for each 

image may vary based on the interface. 

 Static images 

These images come with VMP, as shown in the figure below. 
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 Dynamic images 

These images come with VMP, as shown in the figure below. 

 

Step 4 Set the resolution, refresh rate and bit depth for the internal source. 

Figure 6-9 Internal source parameters 

 

Step 5 After the settings, click Apply.
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7 Display Correction 

This chapter describes output configuration with one device selected. 

7.1 Seams 

7.1.1 Correct Seams 

Adjust the seams between cabinets or modules to improve the display effect. 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

 Receiving cards: A10s Pro, A8s, A8s-N, CA50E, XA50 Pro 

Related Information 

If brightness correction has been done for the screen, the screen brightness can be adjusted in nits. Otherwise, it can 
be adjusted only in percentage. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Correction. 

Step 2 On the Seams tab in the properties area, toggle on the Seam Correction. 

Note 

Currently, apart from the A10s Pro receiving card, the Seam Correction switch will not be displayed on this interface. 

In this case, simply toggling on the Brightness Calibration or Brightness and Chroma Calibration will ensure that 

the seam correction takes effect. 

Step 3 Toggle on Brightness Calibration or Brightness and Chroma Calibration to view the correction effect. 

 Brightness Calibration: Set the Brightness Calibration switch to  to make the screen apply the calibration 

effect made by the calibration platform. 

 Brightness and Chroma Calibration: Set the Brightness and Chroma Calibration switch to  to make the 

screen apply the calibration effect made by the calibration platform. 

The Brightness Calibration and Brightness and Chroma Calibration are mutually exclusive. 

Figure 7-1 Correction (seams) 

 

Step 4 Select a correction mode. 

Figure 7-2 Select mode (seams) 
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 Cabinet Seams: Correct the seams of cabinets. 

 LDM Seams: Correct the seams of modules. 

Step 5 When correcting the module seams, if you need to override the numbers of module columns and rows, click the  

icon next to Select Mode and then perform the settings on the Cabinet Structure Override window. Otherwise, skip 

this step. 

Figure 7-3 Cabinet structure override 

 

Step 6 Set the screen display parameters and check the seam correction effect. 

Figure 7-4 Adjustment (seams) 

 

 Brightness: Adjust the display brightness. 

 Display image: Set the image displayed on the screen. By default, the current input source is being displayed 

( ). You can switch to a monochrome display in white, red, green, and blue. 

To do so, simply press the shortcut keys W, R, G, B, and Tab. 

Note 

You can only configure the displayed image for the currently selected page. All other pages will show a black screen. 

Step 7 In the topology area, click or click and drag the mouse to select the seams to be corrected. 

Step 8 Set the adjustment parameters. 

Figure 7-5 Set the parameters. 

 

 Quick adjust: Has a large range of adjustment. 

 Fine adjust: Has a small range of adjustment. 
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 Hide cursor on screen: When this is enabled ( ), the cursor will not be displayed on the screen while adjusting 

brightness and chroma. 

Step 9 Place the mouse on the scroll wheel icon and adjust the brightness by dragging the wheel icon up or down, scrolling 

the mouse wheel, or using the keyboard shortcuts 1+↑/↓. 

 Restore: Restore the configuration to the last saved. 

 Reset: Reset the configuration to factory defaults. 

Step 10 After the settings, click Save. 

7.1.2 Erase Seam Correction 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

 Receiving cards: A10s Pro, A8s, A8s-N, CA50E, XA50 Pro 

Related Information 

If there are any changes made to the cabinets, such as moving a receiving card from one cabinet to another or 
replacing the cabinet module, it may cause bright or dark lines that had been previously corrected to appear in the 
middle of the cabinet or module. In such cases, you have the option to remove the seam correction that was applied. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Correction. 

Step 2 Select the Cabinet mode. 

Figure 7-6 Select mode (cabinet) 

 

Step 3 Select the target cabinets and then click Erase to remove the seam correction that was applied to them. The erasion 

will be automatically saved to the hardware once you are done. 

Figure 7-7 Erase seam correction 
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7.2 Correct Multi-Batch Cabinets/Modules 

Adjust the chroma of cabinets or modules from multiple batches to make the overall chroma of the display more 
balanced and uniform. 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

 Receiving cards: A10s Pro, XA50 Pro, CA50E (V1.3.0.0 or later) 

Related Information 

If brightness correction has been done for the screen, the screen brightness can be adjusted in nits. Otherwise, it can 
be adjusted only in percentage. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Correction. 

Step 2 On the Modules tab in the properties area, you can enable the correction switches including Brightness Calibration 

and Brightness and Chroma Calibration to view the correction effect. 

 Brightness Calibration: Set the Brightness Calibration switch to  to make the screen apply the calibration 

effect made by the calibration platform. 

 Brightness and Chroma Calibration: Set the Brightness and Chroma Calibration switch to  to make the 

screen apply the calibration effect made by the calibration platform. 

The Brightness Calibration and Brightness and Chroma Calibration are mutually exclusive. 

Figure 7-8 Correction (modules) 

 

Step 3 Select a correction mode. 

Figure 7-9 Selecting mode 

 

 Cabinet: Correct the multi-batch cabinets. 

 Module: Correct the multi-batch modules. 

Step 4 When correcting multi-batch modules, if you need to override the numbers of module columns and rows, click the 

 icon next to Select Mode and then perform the settings on the Cabinet Structure Override window. Otherwise, 

skip this step. 
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Figure 7-10 Cabinet structure override 

 

Step 5 Set the screen display parameters and check the display effect. 

Figure 7-11 Adjustment (modules) 

 

 Brightness: Adjust the display brightness. 

 Display image: Set the image displayed on the screen. By default, the current input source is being displayed 

( ). You can switch to a monochrome display in white, red, green, and blue. 

To do so, simply press the shortcut keys W, R, G, B, and Tab. 

Note 

You can only configure the displayed image for the currently selected page. All other pages will show a black screen. 

Step 6 In the topology area, click or click and drag the mouse to select the cabinets or modules to be corrected. 

Step 7 Adjust the parameters. 

Different colors have different adjustment parameters. These settings can be adjusted using the shortcut keys shown 
in brackets. 

Figure 7-12 Adjustment (White/Red/Blue/Green) 
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 Restore: Restore the configuration to the last saved. 

 Hide cursor on screen: When this is enabled ( ), the cursor will not be displayed on the screen while adjusting 

brightness and chroma. 

 Import Coefs: Import the existing correction coefficients to the current cabinet/module. 

 Export Coefs: Export the correction coefficients of the current cabinet/module 

After setting the parameters of one cabinet, you can right-click to copy the parameters of the current cabinet and 
paste them to other cabinets, or you can use the shortcut keys Ctrl+C/Ctrl+V to complete the copy/paste operation. 

Step 8 After the settings, click Save. 

7.3 Lock and Unlock Correction Page 

After the screen correction is finished, you can lock the Correction page by either of the following methods to avoid 
changing the display content due to misoperation. 

 Right-click the Correction icon and click Lock. Clicking Lock again unlocks the page. 

 

 From the menu bar, choose View > Lock Correction. Clicking Lock Correction again unlocks the page. 

 

Note 

Once the Correction page is locked and you navigate to another page, you will need to manually unlock the page if 

you wish to return to the Correction page. 
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8 Color Processing 

This chapter describes color processing with one device selected. 

8.1 Color Replacement 

Replace a color with another color according to the settings. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro 

Notice 

Replacement of highly saturated colors is recommended for better effect. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 

Step 2 Set the Color Replacement switch to . 

Step 3 Set the colors before and after replacement. 

 Method 1: Click the color area in  to open the color palette and set a color. 

 Method 2: Click the eyedropper in  and select a color in the topology area. 

Figure 8-1 Color replacement 

 

Step 4 Set Hue Tolerance, Hue Softness, Shadow Strength, and Skin Tone Protect. 

 Hue Tolerance: Indicates the hue range of the color to be replaced. The larger the value, the larger the 

replacement area. 

 Hue Softness: Indicates the hue softness of the transition area. 

 Shadow Strength: Indicates the gradient parameter of the highlight or shadow area. The larger the value, the 

smoother the gradient. 

 Skin Tone Protect: Keeps the skin tone as original as possible. 

8.2 14Ch Color Correction 

Precisely adjust the hue, saturation and brightness of black, white, and the 12 derived standard colors of the red, 
green and blue primary colors. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 
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Step 2 Set the 14h Color Correction switch to . 

Step 3 Click a value of a color to enable the editing status and change the value, , for example. 

Parameter Change Trend 

Hue (H) 

Positive values: The color hue angle changes counterclockwise. 

Negative values: The color hue angle changes clockwise. 

Saturation (S) 

Decreases to -100%: The 12 colors gradually become diluted. 

Increases to +100%: The 12 colors become more vivid and rich. 

Brightness (B) 

Decreases to -100%: The 12 colors gradually darken. 

Increases to +100%: The 12 colors become brighter, and the colors appear to be diluted. 

Figure 8-2 14Ch color correction 

 

8.3 Set Curves 

This feature allows you to quickly adjust image brightness and color tone, customize the response curves for red, 
green, blue, and white, and fine-tune highlights and shadows independently. It ensures that highlights are not 
overexposed and that low-grey areas retain rich details. Additionally, you can use this feature to make precise tweaks 
to the screen display, compensating for variations due to ambient light or camera performance. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 

Step 2 Set the Curve switch to . 
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Figure 8-3 Curves 

 

Step 3 Select the white, red, green or blue channel. 

Step 4 Drag the slider at the bottom of the curve diagram to set the curve adjustment range. 

Step 5 Click anywhere on the curve to add an adjustment point and drag the point to adjust the curve. 

Input and Output indicate the absolute coordinates of the adjustment point in the curve diagram. 

To delete the adjustment point, drag the point outside the curve diagram, or select the point and press Delete. 

Click the  icon at the right of Channel to reset the curve of the current channel. Click the  icon next to 
Curves to reset all the curves. 

8.4 Enable 3D LUT 

A 3D Lookup Table file (.cube) defines a set of mappings that enable color adjustments in video sources. Widely used 
in film and image processing, it allows you to modify target colors without affecting neutral grays and other hues. This 
technique addresses blending and layering challenges to ensure smooth color transitions. By providing precise 
control over the entire three-dimensional color space, it delivers a more accurate color representation. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro 

Prerequisites 

Please prepare a 3D LUT file in the .cube format with a file precision of either 17×17×17, 33×33×33, or 65×65×65 (all 
precisions will be processed according to a 17×17×17 base). 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 

Step 2 Click anywhere in the Load 3DLUT File area, select a file and open it. 

Figure 8-4 Loading 3D LUT file 

 

Step 3 Set the 3D LUT to  and and drag the slider to adjust the applying level of the 3D LUT. 
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Figure 8-5 Adjusting intensity 

 

To delete the file, click . 

8.5 Enable Dynamic Booster 

Dynamic Booster can significantly improve the display contrast and image details for better visual experience and 
effectively control and lower the display power consumption. 

Applicable Products 

 LED display controller: MX40 Pro 

 Receiving cards: A10s Pro 

Prerequisites 

Before the operation, color gamut and brightness correction by using the CA410-VP427, CA410-P427 or CA410-
P427H colorimeter must be done. Otherwise, the Dynamic Booster switch is grayed out and the function is 
unavailable. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 

Step 2 Set the Dynamic Booster switch to . 

Step 3 Drag the slider to adjust the applying level of the Dynamic Booster. 

Figure 8-6 Dynamic Booster 
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9 Screen Settings 

9.1 Adjust Image Quality 

9.1.1 Adjustment Mode 

Switch the cabinet display mode to let the screen of the same specifications have the optimal display effect under 
different application scenarios. 

Prerequisites 

The NCP file is uploaded, and the NCP files of the receiving card and the controller must match. For details, see 16.2 
Manage Cabinet Library. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 On the Image Quality tab, select a mode based on the application scenario to let the screen have the optimal display 

effect. 

Figure 9-1 Mode 

 

9.1.2 Adjust Brightness and Gamma 

Manually adjust the screen brightness and gamma to change the screen brightness and chroma performance in real 
time, and enable or disable brightness overdrive as needed. 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

 Receiving cards: A10s Pro, A8s, A8s-N, CA50E, XA50 Pro 

Prerequisites 

To use the brightness overdrive function, please make sure the NCP file is uploaded, and the NCP files of the 
receiving card and the controller must match. For details, see 16.2 Manage Cabinet Library. 

Related Information 

If brightness correction has been done for the screen, the screen brightness can be adjusted in nits. Otherwise, it can 
be adjusted only in percentage. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 On the Image Quality tab, adjust the brightness and gamma value, and enable or disable Brightness Overdrive as 

needed. 
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Figure 9-2 Adjustment 

 

9.1.3 Set LED Image Booster 

Set the LED Image Booster function to improve the delicacy and accuracy of the image color and gradation and 
realize free switching of the display color gamut. 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

 Receiving cards: A10s Pro, A8s, A8s-N, CA50E, XA50 Pro 

Prerequisites 

Before the operation, color gamut and brightness correction by using the CA410-VP427, CA410-P427 or CA410-
P427H colorimeter must be done. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Image Quality tab on the Screen Settings page. In the LED Image Booster area on the right, select an 

output color gamut from the Gamut drop-down list. 

The output gamut options include standard gamuts, custom gamuts, the original screen gamut and the input gamut 
(From input). 

To set the custom gamut, click , select a gamut in the properties area on the color gamut diagram, and adjust the 
red, green, blue and white parameters based on the selected gamut. The custom gamut name can be changed. 

Step 3 Drag the slider to adjust color temperature. 

Step 4 Enable or disable Magic Gray as needed. 

Figure 9-3 LED Image Booster 

 

9.1.4 Set Thermal Compensation 

Adjust the application intensity of the thermal coefficients. 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

 Receiving cards: A10s Pro, A8s, A8s-N, CA50E, XA50 Pro 
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Prerequisites 

Before operation, it is necessary to complete the thermal calibration of the screen. Use the Cabinet Tool to create an 
NCP file containing thermal coefficients and upload it. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 On the Image Quality tab, set the Thermal Compensation switch to . 

Figure 9-4 Thermal compensation 

 

Step 3 You can adjust the thermal coefficients manually or automatically. 

 Manual: Drag the slider to adjust the strength of applying the thermal coefficients. 

 Automatic: The system automatically generates the application strength of thermal coefficients based on the 

screen status and does not support manual modification. 

9.1.5 Adjust EOTF 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

 Receiving cards: A10s Pro, A8s, A8s-N, CA50E, XA50 Pro 

Related Information 

The supported adjustment parameters depend on the HDR settings. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 On the Image Quality tab, drag the sliders to adjust the values of Shadow Compensation, Ambient Light 

Compensation, and Clip Level. 

Figure 9-5 EOTF adjustment 

 

9.2 Set Output 

9.2.1 Set Video Parameters 

Set the output bit depth and additional frame latency. 
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Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 (output bit depth is fixed to 8bit) 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 In the Output tab, select an option from the drop-down list of Bit Depth. 

If Auto is selected, the output bit depth is the same as the input bit depth. 

Figure 9-6 Output bit depth 

 

Step 3 Set a value for Additional Frame Latency. 

When the controller is used with high-latency devices and there is a need to increase the latency, you can adjust the 
value for Additional Frame Latency. 

Note 

It is not possible to set Additional Frame Latency when Low Latency is enabled. 

9.2.2 Set Sync Parameters 

Set the sync source and phase offset. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab. 

Step 3 Select a synchronization signal for the display frame rate and set the phase offset. 

Figure 9-7 Sync 

 

 Canvas Max Frame Rate: This displays the maximum frame rate of the current output card's canvas. If all 

canvases have the same maximum frame rate, it will show the value. If the frame rates are different, it will 

display Mix. 

 Source: Sync with the frame rate of the active source. 
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 Genlock: Sync with the frame rate of the Genlock signal. When the shutter fit function of the controller is 

effective, please select this option. In addition, the controller and the camera need to use the same Genlock 

signal generator. 

 Internal: Sync with the frame rate of the controller's internal clock. 

Note 

 When low latency is enabled, the sync source cannot be set to Genlock. 

 The genlock parameter adjustment only takes effect on the selected device, while other output adjustments 

applies to all devices of the screen. 

9.2.3 Set Frame Multiplication 

Frame multiplication can make the screen output multiple frames within the original one frame time and provide them 
to different cameras. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro 

Related Information 

 Frame multiplication, low latency, and 3D cannot be enabled at the same time. 

 MX6000 Pro and MX2000 Pro are capable of supporting a max frame rate of 480 Hz when using the A10s Pro 

and CA50E receiving cards. 

 MX40 Pro is capable of supporting a max frame rate of 240 Hz when using the A10s Pro receiving card. 

 The specific maximum frame rate that can be set is related to the hardware configuration of the screen. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab and set Frame Multiplication to . 

Figure 9-8 Frame multiplication 

 

Step 3 Set the number of frames and the display mode of each frame. 

Take the above figure as an example. The parameters are described as follows: 

 Frame Multiplication: After the current frame rate (59.94) is multiplied by 3, it is 179.82 Hz. Three frames are 

output in 1/59.94 second. 

 Video: The first and second frames display the input source image. The first frame displays the image from the 

coordinates (0, 0) and the second frame displays the image from the coordinates (1920, 0). 

 Color: The third frame displays a pure white image. 

9.2.4 Set Shutter Fit 

The screen can fit the camera shutter to make the picture shooting have a better effect. 
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Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro 

 Receiving cards: A10s Pro, CA50E, XA50 Pro 

Prerequisites 

It requires that the sync signal must be Genlock and the controller and camera need to use the same Genlock signal 
generator. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab and set Shutter Fit to . 

Figure 9-9 Shutter fit 

 

Step 3 Set the relevant parameters. 

9.2.5 Enable 3D Function 

Enable the 3D function and set the related parameters for all users to wear 3D glasses to view stereoscopic images. 

Applicable Products 

MX40 Pro, MX6000 Pro, MX2000 Pro 

Notice 

The 3D function and the low latency or frame multiplication function cannot be enabled at the same time. 

Related Information 

To use the 3D function, specified 3D glasses are needed. Please contact NovaStar technical support. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab and set 3D to . 

Figure 9-10 3D 

 

Step 3 Set the related parameters. 

 Source Format: Set the format of the 3D video source. Set the format to Side-by-side, Top-and-Bottom or 

Frame Sequential according to the format of the accessed video source. 
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 Right Eye Offset: Set the start position of the right eye image. When the video source format is side-by-side or 

top-and-bottom and the left and right eye images are provided, this parameter can be set. 

 Eye Priority: Set which image is sent first, the right eye image or the left eye image. Wear the 3D glasses to 

watch the display. If the display is abnormal, set the parameter value to the other one. If the display is normal, 

the setting is done. 

 3rd Emitter: When a third-party 3D signal emitter is used, set the switch to . 

 Emitter Delay: Set the delay time of sending the synchronization signal from the 3D signal emitter to the 3D 

glasses. This setting ensures that the switching between left and right eye images of the 3D glasses is in sync 

with the switching between the left and right eye images on the display. This parameter is applicable to both the 

NovaStar and third-party emitters. 

9.2.6 Check the Load 

Check the capacity usage of each Ethernet port of the device. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab. Under Port Load, click  next to the device information to check the usage of the controller's 

load capacity. 

Figure 9-11 Port load 
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10 Backup Settings 

10.1 Device Backup 

You can configure device-level hot backup for devices within the same screen, enabling the backup device to take 
over as the primary device in case of a failure. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Prerequisites 

 A primary device can only have one backup device. 

 The primary and backup devices must be of the same model and firmware version. For card-cased controllers 

(MX6000 Pro and MX2000 Pro), please also make sure the number, slot, model, and firmware version of the 

daughter cards also match. 

 Device backup and Ethernet port backup are mutually exclusive. You can only configure one type of backup at a 

time. For card-cased controllers (MX6000 Pro and MX2000 Pro), device backup, card backup, and Ethernet port 

backup are all mutually exclusive. However, devices that have not been backed up support simultaneous 

configuration of card backup and Ethernet port backup. 

Operating Procedure 

Step 1 Select a screen/device from the project list and then select Backup. 

Figure 10-1 Device backup 

 

Step 2 All devices of the screen will be shown in the canvas area. You can drag and drop a device onto another to establish a 

backup relationship. 

The device being dragged is considered the backup, while the one being dropped onto becomes the primary. Upon 
dropping, a pop-up window will appear showing information about the primary and backup devices. If everything is 
correct, simply click OK. 

Step 3 Click Verify Primary or Verify Backup to examine whether the devices are working properly. 

 Verify Primary: Disconnect the backup and examine whether the primary is working properly. 
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 Verify Backup: Disconnect the primary and examine whether the backup is working properly. 

10.2 Card Backup 

You can configure card-level hot backup for output cards within the same screen, enabling the backup card to take 
over as the primary card in case of a failure. 

Applicable Products 

MX6000 Pro, MX2000 Pro 

Prerequisites 

 The primary and backup output cards must be of the same model and firmware version. 

 Device backup and card backup are mutually exclusive. You can only configure one type of backup at a time. 

Operating Procedure 

Step 1 Select a screen/output card from the project list and then select Backup. 

Step 2 Under the Backup Settings section, select Card Backup from the drop-down list. 

Step 3 Set a backup card for the primary. 

Figure 10-2 Card backup 

 

Step 4 Click Verify Primary or Verify Backup to examine whether the cards are working properly. 

 Verify Primary: Disconnect the backup and examine whether the primary is working properly. 

 Verify Backup: Disconnect the primary and examine whether the backup is working properly. 

10.3 Ethernet Port Backup 

You can configure Ethernet port hot backup within the same device or output card, enabling the backup port to take 
over as the primary port in case of a failure. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Prerequisites 

Device backup and Ethernet port backup are mutually exclusive. You can only configure one type of backup at a time. 
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Operating Procedure 

Step 1 Select a screen/device/output card from the project list and then select Backup. 

Step 2 Under the Backup Settings section, select Ethernet Backup from the drop-down list. 

For card-cased controllers (MX6000 Pro and MX2000 Pro), you need to first select Card Backup before configuring 

Ethernet port backup for the cards. 

Figure 10-3 Ethernet port backup 

 

Step 3 Select an option from the sub-menu of Ethernet backup. 

 Port (1~20) ⇌ (21~40): Split Backup where Ethernet ports 21 to 40 are the backups to Ethernet ports 1 to 20. 

 Port (1 ⇌ 2, 3 ⇌ 4...): Sequential Backup where Ethernet port 2 is the backup to Ethernet port 1, Ethernet port 4 is 

the backup to Ethernet port 3, and so on. 

 Custom: Select a device or output card from the project list, and then you can drag and drop the port icon in the 

port list to customize the backup settings. You can also select a backup mode first and then adjust the backup 

settings according to your needs. 

Figure 10-4 Port list 

 

Note 

You can click Split Backup or Sequential Backup on the right side of the port list to switch between backup modes. 

When hovering the mouse over the line between the Ethernet ports, you will see a  icon. Click the icon to delete 

the backup relationship between the ports. 

Step 4 Click Verify Primary or Verify Backup to examine whether the ports are working properly. 

 Verify Primary: Disconnect the backup and examine whether the primary is working properly. 

 Verify Backup: Disconnect the primary and examine whether the backup is working properly. 
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11 Preset Management 

11.1 Save Presets 

After completing the display effect adjustment, you can save the settings on the Source, Layout, Processing and 
Screen Settings pages as presets so that they can be directly applied in the future. You can save up to 128 presets 

in VMP. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Related Information 

The preset of a specific device can only be applied by this device itself and the preset of a screen can be applied by 
all the devices of the screen. 

Operating Procedure 

Step 1 Select Preset 

Step 2 On the preset management page, click  to enter the page shown in Figure 11-1. 

To go back to the preset management page, click a blank area in the properties area. 

Figure 11-1 Preset management 

 

Step 3 Click a preset icon and in the properties area, set a name for the preset. 

Step 4 Select the data you need to save. You can also enable Transition Through Black as needed. 

If the preset you selected is not empty, the original data will be overwritten. 

Step 5 Click Save. 

11.2 Apply Presets 

Apply a saved preset to quickly complete settings of the parameters on the Source, Layout, Processing and 
Screen Settings pages. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Related Information 

The preset of a specific device can only be applied by this device itself and the preset of a screen can be applied by 
all the devices of the screen. 
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Operating Procedure 

Step 1 Select Preset 

Step 2 On the preset management page, double-click a preset and wait for it to be loaded. 

The preset that is being used has a  at the top right. 

Figure 11-2 Apply presets 

 

11.3 Manage Presets 

Select Preset and do the following operations as needed. 

Modify a Preset 

Select a preset. In the properties area, change the related information and click Save. 

Delete a Preset 

 Right-click a preset and select Delete from the pop-up menu. 

 On the preset management page, select a preset and click Delete in the properties area. 

Clear Presets 

Right-click a preset and select Delete All from the pop-up menu. 
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12 Screen Monitoring 

12.1 Check Device Status 

Check the controller related information and working status, including the receiving card temperature, cabinet voltage 
and total bit error. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Related Information 

Only MX6000 Pro and MX2000 Pro can view the card information. 

Operating Procedure 

Choose Monitor > Status and click the function icons on the left to check the related information. The below figure 

takes MX6000 Pro as an example. 

Figure 12-1 Status 

 

 : The controller. 

− Check the status of the connectors on the rear panel of the controller. 

− Check the controller's name, current uptime, total uptime, mainboard temperature, mainboard voltage, and 

fan status. 

− Check the temperature and voltage of the cards. 

− Set on/off of the Controller Finder switch. When set to , you can locate the controller. 

− Set on/off of the Bit Error switch. When set to , you can monitor the errors. 

− Set on/off of the Fan switch. When set to , you can monitor the fan status and display it in the 

Controller area. 

 : The receiving card temperature. In the properties area, you can check the temperature information. 

 : The cabinet voltage. In the properties area, you can check the voltage information. 
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 : The total bit errors. In the properties area, you can check the detailed information of the errors. Click  

to clear the errors and click  to check the error information in a specified time range. 

Note 

Selecting , , or  enables you to check the cabinet position, voltage, total uptime, and current uptime 

under the Cabinet section of the properties area. You can also blackout, freeze, or enable test patterns for cabinets 

under the Cabinet Settings section. 

12.2 Check Monitoring Records 

Check the exception records of the system. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Operating Procedure 

Choose Monitor > Status and at the bottom of the page, do the operation as needed. 

Figure 12-2 Monitoring records 

 

 Search records 

Enter the key words in the search box. 

 Query records 

Click the time widget and set the start and end time. If you select Now, the monitoring records will be updated in 

real time. 

 Set how the records are displayed 

From the drop-down list, select By Time, By Equipment, By Type, and By Level. If the latter three are 

selected, the records can be expanded or collapsed. 

 Clear records 

Click Delete and then click OK. 

 Export records 

Click Export, select a save path, set a file name, and click Save. 
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13 Display Schedule 

13.1 Create Brightness Schedule 

You can create a brightness adjustment schedule for the LED display screen. When a light sensor is connected to the 
system, it can automatically adjust the brightness of the LED screen based on the real-time ambient light conditions. 
This adjustment occurs within a predetermined time frame, with the sensor measuring the ambient light brightness 
and referring to a mapping policy that correlates the LED display brightness with ambient light levels. 

Applicable Products 

MX6000 Pro, MX2000, Pro MX40 Pro, MX30, MX20, KU20 

Operating Procedure 

Step 1 Select a screen from the project list and then select Schedule. 

Step 2 Click Create Schedule, select the Brightness tab, and then set the date and time range. 

Figure 13-1 Create brightness schedule 

 

Step 3 Specify how the brightness is adjusted, by Light sensor, or by Specified brightness. 

If you choose to adjust by a light sensor, remember to configure the brightness policy on the right side of the interface 
(refer to Step 4 to Step 5). 

Step 4 Select Linear or Stepwise under the Automatic Brightness section to specify how the brightness is adjusted. 

 Linear: When there is a change in ambient brightness across two adjacent ranges, the average brightness value 

is continuously calculated according to the measuring rules, and the screen brightness is then adjusted based 

on the brightness policy. 

 Stepwise: When there is a change in ambient brightness across two adjacent ranges, the screen brightness is 

only adjusted at the range margins according to the brightness policy. 
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Figure 13-2 Brightness policy 

 

Note 

When all the cabinets of the screen support the multi-mode function and use the same NCP file, you can manually 

link the brightness policy to the multi-mode and display data based on the maximum brightness of the multi-mode. 

Step 5 You can add a policy individually or in batch. Up to 29 brightness policies can be added. 

 Batch add: Click Batch Add and then set the Ambient Brightness, Screen Brightness, and Segments in the 

pop-up window. 

 

 Add: Click Add to add a new brightness policy and then adjust the values for Ambient Brightness and Screen 

Brightness. 

 

Step 6 Specify if the schedule should repeat and provide the end time for the repetition. 

Step 7 Click OK once you are done. The created schedule will be displayed in the schedule chart. 

You can click  on the top-left corner to switch between daily view, weekly view, and monthly view 
to review the overall schedule plan. 
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Step 8 Right-click a schedule in the chart to Edit or Delete it. 

Edit: You can edit the Current schedule or Current and follow-up schedules. 

Delete: You can delete the Current schedule, Current and follow-up schedules, or All schedules 

Step 9 To activate the schedule, please toggle on Schedule in the upper right corner of the chart. 

Figure 13-3 Schedule 

 

Note 

Brightness schedule and HDR 2084 cannot be enabled at the same time. If brightness schedule is enabled after HDR 

2084 is selected, the HDR function will be disabled. 

13.2 Create Preset Schedule 

You can create a predetermined schedule for the LED screen, enabling automatic switching of different presets 
according to the specified timetable. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Prerequisites 

You need to save a preset for the screen before creating a preset schedule. 
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Operating Procedure 

Step 1 Select a screen from the project list and then select Schedule. 

Step 2 Click Create Schedule, select the Preset tab, and then set the date and time range. 

 

Step 3 Select the preset to be applied. 

Step 4 Specify if the schedule should repeat and provide the end time for the repetition. 

Step 5 Click OK once you are done. The created schedule will be displayed in the schedule chart. 

You can click  on the top-left corner to switch between daily view, weekly view, and monthly view 
to review the overall schedule plan. 

 

Step 6 Right-click a schedule in the chart to Edit or Delete it. 

Edit: You can edit the Current schedule or Current and follow-up schedules. 

Delete: You can delete the Current schedule, Current and follow-up schedules, or All schedules 

Step 7 To activate the schedule, please toggle on Schedule in the upper right corner of the chart. 
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Figure 13-4 Schedule 

 

13.3 Check Schedule Log 

You can check the schedule log and history charts. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Operating Procedure 

Select Schedule and at the bottom of the page, do the operation as needed. 

Figure 13-5 Log 

 

 Search records 

Enter the key words in the search box. 

 Query records 

Click the time widget and set the start and end time. 

 History Charts 

Click  and select a specific date to access the history charts displaying the brightness 
schedule and preset schedule log. Please note that you can only view the history on a daily basis. 
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Figure 13-6 History charts 

 

 Export records 

Click Export, select a save path, set a file name, and click Save. 

14 Calibration Coefficient Management 

From the menu bar, choose Tools > Coefficient Management and do operations such as uploading, saving, 

adjusting and reading the coefficients. You can also check the module flash status. 

 

14.1 Check Module Flash Status 

When replacing modules or reading back coefficients from the module flash, you have the option to visually inspect 
the status of the module flash. 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 On the canvas, click  to display the module flash status. Click  again to hide the module status. Click  to 

refresh the module status. 

  : Module flash is abnormal. 
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 : Module flash is normal. 

Figure 14-1 Check module flash status 

 

14.2 Upload Calibration Coefficients 

Upload the local calibration coefficient file to the current screen, cabinet or module and apply the coefficients to the 
display effect. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Prerequisites 

 You can only upload coefficients from page 1. 

 

 To upload screen coefficients, make sure: 

− The screen configuration is done, the cabinets are not rotated, and there are no cabinet gaps or overlapping. 

− The configured screen must be rectangular, and the top-left-corner coordinates of the circumscribed 

rectangle of the configured screen must be (0, 0). 

− To use the database file, you should prepare it in advance, and the resolutions of the configured screen and 

the screen in the database must be the same and the database must be a screen database. 

 To upload cabinet coefficients, make sure: 

The target cabinets have cabinet IDs. You will need to configure cabinet ID manually if the target cabinets have 
no ID. 

Notice 

During coefficient uploading, if the controller and/or receiving cards go offline, the uploading will fail. 

If the coefficient uploading fails, the coefficients will not be saved automatically. You can manually save them as 
needed. 

Operating Procedure 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select the uploading range. The options include Screen, Cabinet and LDM. 
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Figure 14-2 Select mode 

 

Step 4 In the Coefficient Management area, click  and select the target calibration data file (.db) from the local 

computer. 

The coefficient types in the file will be read automatically. You can select the range of coefficient types as needed. 

Figure 14-3 Upload calibration coefficients 

  

Step 5 Click OK to upload the coefficients to receiving cards. 

14.3 Edit Calibration Coefficients 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Prerequisites 

 Calibration coefficients are available. 

 Cabinet configuration is done and the cabinets stay online. 

Operating Procedure 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select Pixel. 

Figure 14-4 Select mode 

 

Step 4 In the topology, click to select a cabinet. 

Step 5 In the displayed window, select the target pixels and enter the parameters in the Coefficient Management area to 

adjust the proportion relationship of the red components, green components and blue components in RGB. 

The calibration coefficients of the selected pixels will be overridden and changed to the values you set. 
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Figure 14-5 Pixel calibration coefficients 

 

Table 14-1 Table 12-1 Parameter relationship and value range 

/ Red-R Green-G Blue-B 

Red-R RR (512 — 2047) GR (0 — 255) BR (0 — 127) 

Green-G RG (0 — 255) GG (512 — 2047) BG (0 — 255) 

Blue-B RB (0 — 127) GB (0 — 127) BB (512 — 2047) 

Table 14-2 Icon description 

Icon Description 

 The step of single increase or decrease. Use it together with . 

 
Increase or decrease the coefficient value of the selected pixel. 

 
Click to close the pixel topology. 

14.4 View Calibration Effect 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Related Information 

If brightness correction has been done for the screen, the screen brightness can be adjusted in nits. Otherwise, it can 
be adjusted only in percentage. 

Set the Display Content 

In the Display area, you can adjust the screen brightness to clearly see the actual calibration effect change at each 

grayscale. You can also switch the color to see the uniformity of a single color and the entire display image. 
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Figure 14-6 Set display content 

 

 Brightness: Adjust the screen brightness. 

 Display image: Set the image displayed on the screen. By default, the current input source is being displayed 

( ). You can switch to a monochrome display in white, red, green, and blue. 

To do so, simply press the shortcut keys W, R, G, B, and Tab. 

 Show locating cursor: When the switch is set to , the selected area on the screen will display blue borders. 

This helps you quickly locate the cabinets, modules or pixels that you are currently operating. 

Enable and Disable Calibration Effect 

In the Calibration area, you can turn on or off the calibration switches and then view the display effects before and 

after the calibration. 

The calibration switches include Brightness Calibration, Brightness and Chroma Calibration, Full-Grayscale 
Calibration and Low-Grayscale Calibration. The actual displayed switches depend on the existing coefficient types 

of the screen. 

Figure 14-7 Calibration switches 

 

The Brightness Calibration and Brightness and Chroma Calibration are mutually exclusive and cannot be 

enabled at the same time. 

14.5 Save and Read Back Calibration Coefficients 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Notice 

During coefficient saving or readback, if the receiving cards go offline, the uploading or readback will fail. 

Save Calibration Coefficients 

Save the calibration coefficients of the current screen, cabinet or module to the receiving card to avoid calibration 
effect loss due to power failure. 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select the saving range as needed, including Screen, Cabinet, LDM and Pixel. 
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Figure 14-8 Select mode 

 

Step 4 In the Coefficient Management area, click Save to save the current display effect coefficients to the receiving card. 

If the module has flash memory, it will also be saved to the flash. 

The coefficient types of the current screen will be read automatically. You can select the range of coefficient types as 
needed. 

Figure 14-9 Save coefficients 

 

Step 5 Click OK. 

Read Back Calibration Coefficients 

Read back the calibration coefficients saved in the receiving card and apply them to the current screen. 

Step 1 Select a controller from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select the reading range as needed, including Screen, Cabinet, LDM and Pixel. 

Figure 14-10 Select mode 

 

Step 4 In the Coefficient Management area, click Read to read the saved coefficients and apply them to the display effect. 

The coefficient types saved in the receiving card will be read back automatically. If the module has flash memory, it 
will also read from the flash. You can select the range of coefficient types as needed. 
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Figure 14-11 Read back coefficients 

 

Step 5 Click OK. 

14.6 Export Calibration Coefficients 

Export the calibration coefficients of the current screen, cabinet or module to the local computer. When the receiving 
card is replaced or the new screen has the same specifications, you can upload the exported calibration coefficients 
directly to use. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 

Prerequisites 

 You can only export coefficients from page 1. 

 

 To export screen coefficients, make sure: 

− The screen configuration is done, the cabinets are not rotated, and there are no cabinet gaps or overlapping. 

− The configured screen must be rectangular, and the top-left-corner coordinates of the circumscribed 

rectangle of the configured screen must be (0, 0). 

 To export cabinet coefficients, make sure: 

The target cabinets must have cabinet IDs. 

Notice 

During coefficient exporting, if the controller or receiving cards go offline, the exporting will fail. 

Operating Procedure 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select the export range as needed, including Screen, Cabinet, LDM and Pixel. 
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Figure 14-12 Select mode 

 

Step 4 In the Coefficient Management area, click Export to export the current display effect coefficients as a file (.db). 

The coefficient types of the current screen will be read automatically. You can select the range of coefficient types as 
needed. 

Figure 14-13 Export coefficients 

 

Step 5 Click OK.
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15 Screen Maintenance 

15.1 Maintain Controllers 

Step 1 From the menu bar, choose Tools > Maintain. 

Step 2 Select a project, screen group, screen, or controller from the project list on the left. 

Step 3 On the Controller page, select the target controllers and perform the following operations as needed. 

Figure 15-1 Controller maintenance 

 

 Controller finder 

Click Controller Finder and the LCD screen of the controller becomes green, which helps you find the 

controller quickly. 

 Sync card firmware 

If the card firmware version does not match with the controller firmware version, you can click Sync Card 
Firmware to sync the controller firmware to the card. Alternatively, you can resolve this issue by upgrading the 

firmware. 

 Upgrade firmware 

Click Upgrade, select the firmware program file (.img) or .zip file and click Open. On the displayed window, 
double-check the uploaded file name and version and click Update to start upgrading. 

During the upgrade process, the controller will automatically restart. In addition, please do not close VMP or 
switch to another controller until the upgrade is complete. 
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Note: 

 It is recommended to perform the upgrade using a wired network. 

 All the devices of a screen must be upgraded at the same time. 

 When upgrading card-based controllers (MX6000 Pro and MX2000 Pro), all of the cards must be upgraded 

at the same time. If the cards span across different screens, the devices that are under the same screen 

as the card must also be upgraded together. 

 

 Restart the controller 

Click Restart and click OK. 

 Reset settings (proceed with caution) 

Click Reset and click OK. 

15.2 Maintain Cabinets 

Related Information 

For the cabinet painter operation, the configuration parameters of the cabinet to be copied can be saved to local 
computer as an .rpkg file for future use. 

Operating Procedure 

From the menu bar, choose Tools > Maintain and select the Cabinet tab. In the project list, select the target screens 

and perform the following operations on the cabinets as needed. 

Figure 15-2 Cabinet maintenance 

 

Select the target cabinets and perform any of the following operations. 
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 Check the cabinet information 

Check the cabinet status, manufacturer, model, firmware version, location, etc. 

 Copy the firmware program and configuration file 

Click Cabinet Painter and select one or multiple cabinets so that other cabinets can have the same firmware 

program and configuration file as the current cabinet. 

 Restart the cabinet 

Click Restart and click OK. 

 Upload the NCP file, firmware program, configuration file, image quality file and update cabinet 

a. On the Cabinet tab page, select one or multiple cabinets, and then click Update. 

 

b. Click Import and upload the file. 

To upload NCP file, select NCP File. 

To upload firmware program, select Firmware. 

To upload configuration file, select Config File. 

To upload image quality file, select Image Quality File. 

c. Select the target row of cabinet data and click Update. 

Note: 

 It is recommended to perform the update using a wired network. 

 When COEX series controllers work with the A10s Pro , A8s Pro , CA50E or XA50 Pro receiving card, you 

can only perform the update using (.ncp) files. 

 Refresh information 

Click Refresh. 
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16 Software Settings 

16.1 Change Language and Temperature Scale 

 From the menu bar, choose Settings > 语言/Language, and then select the desired language option. 

 From the menu bar, choose Settings > Preference, and then select the desired temperature scale. 

Figure 16-1 Changing the language/temperature scale 

 

16.2 Manage Cabinet Library 

From the menu bar, choose Settings > Cabinet Library. Click Manage Packs and do the following operations as 

needed to manage the cabinet library files. 

 

Upload NCP File 

Step 1 Click Add. On the displayed window, click Upload File. 
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Figure 16-2 Adding NCP file 

 

Step 2 Select the object to be imported (multiple objects can be selected). 

 When Local pack is selected, the file will be stored in the VMP installation directory. 

 When Device pack is selected, the file will be stored in the internal space of the controller. 

Step 3 Select the .ncp file to be imported from the local computer and click Add. 

After the file is selected, you can click Delete to delete the uploaded file. 

You can also click Refresh to refresh the NCP file list. 

Export NCP File 

Step 1 Select one or more files on the Manage Packs screen and then click Export. 

For batch export, multiple files will be compressed as a .zip file and exported. 

Step 2 Select a local directory and click Save. 

Figure 16-3 Successful export 

 

Sync NCP File 

 Sync NCP files between the device and local computer 

Select the files to be synced (multiple files can be selected), and click . 

 

 Sync NCP files between devices 

a. Select the files to be synced (multiple files can be selected), and click Sync NCP. 

b. On the displayed window, select the devices to which the files are synced (multiple devices can be 
selected). 

c. Click Sync. 
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Check NCP File Information 

Select an NCP file, and the information about all the cabinets that use this NCP file will be displayed in the Cabinet 
List area below. The information includes status, cabinet type, resolution, maximum frame rate, receiving card type, 

release status, version and revision. 

 

16.3 Check User Manual 

From the menu bar, choose Help > User Manual to open and check the VMP user manual. 

16.4 Check Software Information 

From the menu bar, choose Help > About and check the software information. 

16.5 Check Keyboard Shortcuts 

From the menu bar, choose Help > Keyboard Shortcuts and check the commonly used software operation 

shortcuts. 
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